Quantcast
View Bug Report
Pet Battle Error
Bug #: 8054
File: TipTop
Date: 12-07-13 09:10 PM
By: def9
Status: Unconfirmed
I'm using v2.13.2 from wowinterface. When ever I enter a pet battle and mouse over a pet mine or the enemy I get the below error. I've disabled all other adds and used a clean wtf directory and still get it. After the error mousing over any pet shows full health sometimes even when they are dead. I have no idea what's causing this just thought you may want to know.

Thanks for all the hard work in maintaining this addon its long been one of my favorites.

Code:
Date: 2013-12-07 22:04:37
ID: 1
Error occured in: Global
Count: 12
Message: ..\AddOns\TipTop\tiptop.lua line 296:
   attempt to concatenate local 'class' (a nil value)
Debug:
   TipTop\tiptop.lua:296:
      TipTop\tiptop.lua:269
   TipTop\tiptop.lua:461:
      TipTop\tiptop.lua:459
   TipTop\tiptop.lua:525:
      TipTop\tiptop.lua:523

RSS 2.0 Feed for Bug CommentsNotes Sort Options
By: def9 - 12-09-13 11:55 PM

Sorry I thought this was licked but when I started playing again recently its still happening. I'm wondering by a uneducated glance at the code I use class coloring on border.

Could this be happening due to pets being defined as "beast, flying, humanoid, etc" and this is causing an error on a mouseover event since these "classes" aren't defined in the mod?
By: Seerah - 12-10-13 09:22 PM
Sorry, def9, I haven't been able to check this out yet. It's review week currently at my school with exams next week. Teachers have a short supply of time during this part of the year. (Not to mention my choir has a concert this weekend.) I will certainly remember to check into it, though.
By: def9 - 12-11-13 08:27 AM
No worries its a minor inconvenience nothing more. Good luck on your exams .