View Bug Report
Error - Unspecified I/O Error
Bug #: 5253
File: WoWInterface UI Manager - Windows
Date: 12-09-08 10:37 AM
By: MaMoose_01
Status: Unconfirmed
I receive "Error - Unspecified I/O Error" when trying to update Auctioneer Suite and Gatherer.

All other updates work just fine. UI manager backs up the current interface then I receive the Error message during the install.

XP pro SP3
Anti virus was disabled during while UI manager is running.

I have since then manually installed Gatherer and Auctioneer Suite, but UI Manager still beleives I am using an outdated version and tries to update and fails.

~*~*~*~*~*~error.txt*~*~*~*~*~*~*~*~*~

!!! 2008-11-09_11-25-58-718> Terminating thread 'AUP-Gatherer': Unspecified I/O Error
java.util.zip.ZipException: duplicate entry: World of Warcraft/WTF/Account/OXOMAMOOSEOXO/SavedVariables/SlideBar.lua
at java.util.zip.ZipOutputStream.putNextEntry(Unknown Source)
at wowiupdater.AddonExtractor.add(AddonExtractor.java:184)
at wowiupdater.AddonUpdateProcess.AddSavedVars(AddonUpdateProcess.java:1471)
at wowiupdater.AddonUpdateProcess.BackupAndDelete(AddonUpdateProcess.java:1220)
at wowiupdater.AddonUpdateProcess.UIReplace(AddonUpdateProcess.java:808)
at wowiupdater.AddonUpdateProcess.run(AddonUpdateProcess.java:414)
at java.lang.Thread.run(Unknown Source)


!!! 2008-11-09_11-29-51-265> Terminating thread 'AUP-Auctioneer Suite': Unspecified I/O Error
java.util.zip.ZipException: duplicate entry: World of Warcraft/WTF/Account/OXOMAMOOSEOXO/SavedVariables/SlideBar.lua
at java.util.zip.ZipOutputStream.putNextEntry(Unknown Source)
at wowiupdater.AddonExtractor.add(AddonExtractor.java:184)
at wowiupdater.AddonUpdateProcess.AddSavedVars(AddonUpdateProcess.java:1471)
at wowiupdater.AddonUpdateProcess.BackupAndDelete(AddonUpdateProcess.java:1220)
at wowiupdater.AddonUpdateProcess.UIReplace(AddonUpdateProcess.java:808)
at wowiupdater.AddonUpdateProcess.run(AddonUpdateProcess.java:414)
at java.lang.Thread.run(Unknown Source)

~*~*~*~*~*~error.txt*~*~*~*~*~*~*~*~*~

I hope this helps, I do appreciate your time in putting this together as it is extremely nice app to have.

RSS 2.0 Feed for Bug CommentsNotes Sort Options
By: FrankN - 12-09-08 04:26 PM
It is the same error I have (http://www.wowinterface.com/portal.php?id=294&a=viewbug&bugid=5240). The reason for the error is both are using SlideBar, which confuses the Updater. Only way for me to "fix" it, was removing both addons completely from the addon folder and install them fresh together. I have not tried to remove only SlideBar, maybe it works as well.