Files 1
Downloads 205,275
Favorites 1,933
My AddOns
View Bug Report
Error popped immediately upon login on a supposedly clean install
Bug #: 7790
File: Altoholic
Date: 09-12-12 03:07 PM
By: Barleduq
Status: Unconfirmed
I dunno what I did, this time. Supposedly a clean install from the 5.0.5 patch, no addons. I pulled mine down, logged in the first toon, and got this:

Code:
Date: 2012-09-12 16:58:45
ID: 1
Error occured in: Global
Count: 1
Message: ...terface\AddOns\DataStore_Crafts\DataStore_Crafts.lua line 258:
   table index is nil
Debug:
   ...terface\AddOns\DataStore_Crafts\DataStore_Crafts.lua:258:
      ...terface\AddOns\DataStore_Crafts\DataStore_Crafts.lua:251
   ...terface\AddOns\DataStore_Crafts\DataStore_Crafts.lua:923:
      ...terface\AddOns\DataStore_Crafts\DataStore_Crafts.lua:907
   (tail call): ?
   [C]: ?
   [string "safecall Dispatcher[1]"]:9:
      [string "safecall Dispatcher[1]"]:5
   (tail call): ?
   ...\AddOns\DataStore\libs\AceAddon-3.0\AceAddon-3.0.lua:543: EnableAddon()
   ...\AddOns\DataStore\libs\AceAddon-3.0\AceAddon-3.0.lua:636:
      ...\AddOns\DataStore\libs\AceAddon-3.0\AceAddon-3.0.lua:621
   [C]: LoadAddOn()
   ..\FrameXML\UIParent.lua:299: UIParentLoadAddOn()
   ..\FrameXML\UIParent.lua:373: TimeManager_LoadUI()
   ..\FrameXML\UIParent.lua:690:
      ..\FrameXML\UIParent.lua:657
Locals:
None
AddOns:
  Swatter, v4.0.3 (<%codename%>)
  ACP, v3.4 
  Altoholic, v5.0.001c
  Analyst, v1.2.0
  Archy, v1.8.29
  AutoRepair, v
  Compass, v1.0.4
  DataStore, v5.0.001
  DataStoreAchievements, v5.0.001
  DataStoreAgenda, v5.0.001
  DataStoreAuctions, v5.0.001
  DataStoreCharacters, v5.0.001
  DataStoreContainers, v5.0.001
  DataStoreCrafts, v5.0.001
  DataStoreCurrencies, v5.0.001
  DataStoreInventory, v5.0.001
  DataStoreMails, v5.0.001
  DataStorePets, v5.0.001
  DataStoreQuests, v5.0.001
  DataStoreReputations, v5.0.001
  DataStoreSpells, v5.0.001
  DataStoreStats, v5.0.001
  DataStoreTalents, v5.0.001
  DebugLib, v5.1.DEV.312(/embedded)
  DragEmAll, v1.0.3
  Dresser, v3.2.1
  Elephant, v3.1.3
  FBMergeDatabase, v1.0.9b
  FBOutfitDisplayFrame, v1.0.9
  FBTrackingFrame, v1.0.9b
  FishingBuddy, v1.0.9e
  LightHeaded, v352
  MacroBank, v1.11
  Postal, v3.5.0
  SimpleGold, v1.99
  Stubby, v5.14.5335 (KowariOnCrutches)
  SwindlerPreventer, v5.0.1 (15799) BETA
  BlizRuntimeLib_enUS v5.0.5.50001 <us>
  (ck=3ec)
I hope at least some of this is useful... please tell me to stop if it isn't.

RSS 2.0 Feed for Bug CommentsNotes Sort Options
By: Pebbles97321 - 09-17-12 06:09 AM
I have this same error on Bloodhoof and Nesingwary everytime I log into one of my toons. I have been trying to dig up a more recent version of datastore since it seems this version has not been updated since late in Wrath. Love my altoholic addon, but datastore needs some TLC for sure. Keep up the great work guys Your awesome!!!