View Bug Report
[3.1.12] "bad arg1 to pairs", can't see temp enchants
Bug #: 5865
File: Satrina Buff Frames 3
Date: 05-27-09 02:03 AM
By: Phanx
Status: Fixed
Upon logging in on any character with SBF 3.1.12, I receive the following error:
Code:
[2009/05/27 00:30:23-2611-x1]: SatrinaBuffFrame-3.1\SatrinaBuffFrame.lua:124: bad argument #1 to 'pairs' (table expected, got nil)
SatrinaBuffFrame-3.1\SatrinaBuffFrame.lua:124: in function <...terface\AddOns\SatrinaBuffFrame\SatrinaBuffFrame.lua:49>
(tail call): ?:
<in C code>: ?
<string>:"safecall Dispatcher[1]":9: in function <[string "safecall Dispatcher[1]"]:5>
(tail call): ?:
Ace3\AceAddon-3.0.lua:502: in function `InitializeAddon'
Ace3\AceAddon-3.0.lua:614: in function <Interface\AddOns\Ace3\AceAddon-3.0.lua:607>
Additionally, temporary weapon enchants (such as shaman weapon imbues) are not displayed.

The issue still occurred when logging in without any saved variables present, and when logging in with no addons other than SatrinaBuffFrame and SBFOptions enabled.

Commenting out lines 124-126 in SatrinaBuffFrame.lua:
Code:
  for index,data in pairs(self.sounds) do
    SML:Register("sound", data[1], data[2])
  end
...resolved the issue, and I found no missing functionality in-game after doing so.

RSS 2.0 Feed for Bug CommentsNotes Sort Options
By: Satrina - 05-27-09 06:46 AM
Is the SatrinaBuffFrame/Media directory present with an SBFSounds.lua file resident?
By: Satrina - 05-27-09 08:31 AM
This is most likely a missing SBFSounds.lua file. I've added a check to make sure that the expected table is actually present for the next release to prevent the error and just give a message.
 
Stats
Files: 13
Downloads: 357,957
Favorites: 1,834

Menu
» Home



New & Updated
» Digits


WOWInterface