Quantcast
ckknight's Avatar
Files 15
Downloads 2,863,625
Favorites 15,205
View Bug Report
Cannot find a library instance of Jostle-2.0
Bug #: 2557
File: FuBar 3.6.5
Date: 12-08-06 12:13 PM
By: Heruwar
Status: Unconfirmed
I've been trying all kinds of different fubar2 and ace2 versions from Curse-gaming, wowace and wowinterface, but they all seem to give me the same error:

Interface\addons\fubar\fubar_panel.lua:5:
Cannot find a library instance of Jostle-2.0.

I even tried to only enable fubar2 and Ace2, but I still got the same error. The latest version i tried with was FuBar-2.0.18841. :(

Am I missing some oteher addons or something, or does fubar just hate me?

RSS 2.0 Feed for Bug CommentsNotes Sort Options
By: Sliverpix - 12-08-06 10:54 PM
Think I found a workaround/fix. Since I DONT code AddOns for WoW dont expect too much. I DO code, just not WoW Addons... hehe

so here is what I did to fix the problem. I dont know if I can/should (even try) to upload due to server traffic curently so here is what I did:

Changed: 12-8-2006 @ 22:18
..:: Sliverpix ::..

Added libraries called for in the FuBar.toc to the \libs\directory

++ AceLibrary\AceLibrary.lua
++ AceOO-2.0\AceOO-2.0.lua
++ AceEvent-2.0\AceEvent-2.0.lua
++ AceAddon-2.0\AceAddon-2.0.lua
++ AceLocale-2.2\AceLocale-2.2.lua
++ AceHook-2.1\AceHook-2.1.lua
++ AceDB-2.0\AceDB-2.0.lua
++ AceConsole-2.0\AceConsole-2.0.lua
++ Dewdrop-2.0\Dewdrop-2.0.lua
++ Jostle-2.0\Jostle-2.0.lua


you may have to look around other places to find some of these, but many of them are already in OTHER addons. Just look in your <wow install path>\interface\AddOns and see whats there.

Hope this elevates some of the strain on the REAL coders ... buy ya some time or something