Quantcast
Download
(2 MB)
Download
Updated: 11-29-20 06:20 AM
Pictures
File Info
Compatibility:
Shadowlands patch (9.0.2)
Classic Patch (1.13.5)
Shadowlands pre-patch (9.0.1)
Updated:11-29-20 06:20 AM
Created:unknown
Downloads:3,384,041
Favorites:6,069
MD5:
9.0.2

TomTom  Updated less than 3 days ago!  Popular! (More than 5000 hits)

Version: v90002-1.1.9
by: Cladhaire, Ludovicus

TomTom is your personal navigation assistant in World of Warcraft. This addon is very simple, but provides a nice set of functionality. Thanks to Esamynn for Astrolabe, which does the bulk of the work in this addon.

TomTom offers the following major features:

  • Set waypoints via command, or by clicking on the world map
  • A draggable coordinate display with customizable accuracy. This frame can be hidden or locked.
  • Player and cursor coordinates on the World Map (these can be hidden)
  • A floating "crazy-taxi" style arrow that points you to your destination
  • Displaying the "crazy-taxi" arrow or coordinate block in compatible LDB displays (such as NinjaPanel)
  • Show a waypoint that points you towards your corpse for easy recovery
  • Can set waypoints by clicking on quest objective POIs on the World Map and watch frame.
[*]Can automatically set waypoints to your closest quest objective
Please also check out LightHeaded: http://www.wowinterface.com/download...ghtHeaded.html
Slash Commands:
/tomtom - Opens configuration GUI

In addition you can use the /way command to add and reset waypoints. In order to overcome conflicts with the Cartographer /way command, you can also use /tway to access TomTom's waypoint command. The following slash commands are available:

Add a new waypoint at 14.78, 23.90:
Code:
/way 14.78 23.90
Add a new waypoint in Nagrand at 45, 50:
Code:
/way Nagrand 45 50
Add a new waypoint with a description:
Code:
/way 14.78 23.90 This is a waypoint!
Remove ALL current waypoints:
Code:
/way reset all
Remove all waypoints in Nagrand:
Code:
/way reset Nagrand
Set a waypoint at the current location:
Code:
/wayb
or
Code:
/wayback
Set the waypoint arrow to the closest arrow in the current zone:
Code:
/cway
or
Code:
/closestway
When you set a waypoint, a dot will appear (green) on your minimap. When it goes out of range of the minimap display, it will turn into an arrow, just like the default UI. You can mouse over these waypoints to get detailed information about that waypoint.

TomTom has been designed to publish the Crazy-Arrow and Coordinate Block as LDB feeds, allowing them to be displayed in compatible display addons. I've written a very simple, easy-to-configure panel that is capable of displaying these called NinjaPanel.

If you're looking to bulk import waypoints (to track achievements, etc), a community member has provided a great addon that lets you do this easily. Take a look at Paste.

Bugs fixed since v90001-1.1.5[list][*] HBD's GetPlayerZonePosition() seems laggy. Roll our own for now.[*] Update reference from GetQuestLogIndexByID to C_QuestLog.GetLogIndexForQuestID (1.1.7)[*] Set default modifier from Control to Alt.[*] Improved QuestPOI integration for retail. (1.1.6)[*] Call EnableDisablePOIIntegration() and ReloadWaypoints after PLAYER_LOGIN. (1.1.6)

Please note that you need to change your default modifier from Control to Alt, if you want to use TomTom from the main map.
Beta Files (1)
File Name
Version
Hits
Size
Author
Date
v90001-1.1.7
228
2MB
Ludovicus
11-09-20 02:33 PM


Archived Files (47)
File Name
Version
Size
Author
Date
v90002-1.1.8
2MB
Cladhaire
11-26-20 09:42 AM
v90001-1.1.5
2MB
Cladhaire
10-19-20 08:31 AM
v80300-1.1.1
2MB
Cladhaire
02-05-20 03:26 PM
v80300-1.1.0
2MB
Cladhaire
01-16-20 06:19 PM
v80205-1.0.8
2MB
Cladhaire
11-03-19 03:21 PM
v11302-1.0.8
2MB
Cladhaire
11-03-19 03:18 PM
v80205-1.0.7
2MB
Cladhaire
09-24-19 03:56 PM
v80200-1.0.5
2MB
Cladhaire
08-02-19 02:20 PM
v80200-1.0.3
400kB
Cladhaire
07-03-19 03:59 PM
v80105-1.0.0
400kB
Cladhaire
03-18-19 05:31 PM
v80100-1.0.1
399kB
Cladhaire
03-11-19 06:27 PM
v80001-1.0.2
412kB
Cladhaire
08-05-18 04:31 PM
v80001-1.0.1
411kB
Cladhaire
07-28-18 10:49 AM
v80001-1.0.0
411kB
Cladhaire
07-23-18 06:06 AM
v70300-1.0.0
388kB
Cladhaire
11-13-17 03:53 PM
v70200-1.0.0
387kB
Cladhaire
04-06-17 10:54 AM
v70100-1.0.1
387kB
Cladhaire
03-26-17 12:49 PM
v70100-1.1.0
387kB
Cladhaire
11-10-16 02:07 PM
v70000-1.1.0
387kB
Cladhaire
08-11-16 11:32 AM
v70000-1.0.0
387kB
Cladhaire
07-19-16 11:59 PM
v60200-2.1.0
386kB
Cladhaire
10-18-15 11:46 AM
v60200-2.0.0
386kB
Cladhaire
09-19-15 09:25 PM
v60200-1.0.0
430kB
Cladhaire
06-27-15 02:35 AM
v60100-1.0.0
430kB
Cladhaire
03-15-15 04:54 AM
v60000-1.1.1
430kB
Cladhaire
12-20-14 03:52 AM
v60000-1.1.0
430kB
Cladhaire
12-13-14 05:46 AM
v60000-1.0.1
430kB
Cladhaire
10-26-14 04:01 AM
v60000-1.0.0
430kB
Cladhaire
10-20-14 01:54 PM
v50400-1.0.0
427kB
Cladhaire
09-11-13 11:28 PM
v50300-1.0.1
425kB
Cladhaire
06-08-13 02:08 AM
v50300-1.0.0
425kB
Cladhaire
06-07-13 01:28 AM
v50200-1.0.2
416kB
Cladhaire
03-05-13 09:53 PM
v50100-1.0.2
415kB
Cladhaire
01-12-13 03:49 AM
v50100-1.0.1
415kB
Cladhaire
11-29-12 11:26 PM
v50100-1.0.0
414kB
Cladhaire
11-28-12 02:16 PM
v50001-1.3.0
414kB
Cladhaire
10-28-12 11:00 AM
v50001-1.2.1
413kB
Cladhaire
10-12-12 12:06 AM
v50001-1.2.0
413kB
Cladhaire
10-10-12 12:28 AM
v50001-1.1.1
412kB
Cladhaire
10-08-12 02:38 AM
v50001-1.1.0
412kB
Cladhaire
10-08-12 12:25 AM
v50001-1.0.4
412kB
Cladhaire
10-05-12 02:12 AM
v50001-1.0.3
410kB
Cladhaire
10-02-12 01:12 AM
v50001-1.0.2
410kB
Cladhaire
09-02-12 02:18 AM
v50001-1.0.2
410kB
Cladhaire
09-02-12 02:18 AM
v50001-1.0.1
410kB
Cladhaire
08-29-12 03:05 PM
v50001-1.0.0
410kB
Cladhaire
08-29-12 10:34 AM
v40300-1.4.5
408kB
Cladhaire
07-08-12 04:45 AM


Post A Reply Comment Options
Unread Today, 05:49 AM  
Cladhaire
Salad!
 
Cladhaire's Avatar
Premium Member
AddOn Author - Click to view AddOns

Forum posts: 1935
File comments: 4799
Uploads: 19
Re: Re: TomTom not working since Shadowlands pre-patch

Originally Posted by Mazona
Originally Posted by essex23
So I have been using TomTom for a bit now...not long, but I really enjoyed having my nice, friendly little green arrow pointing me where I needed to go. But since the pre-patch...he seems to have gone AWOL. I think Sylvanas has done something dastardly to him because all my attempts to coax him out from his hiding hole are not working.
I've been trying to figure this one out today, and my feeling is that the current version of the AddOn (1.1.9) maybe doesn't fully work in the current version of WoW (9.0.2)? (Haven't tried any alpha or beta versions, if such exist.)

It has been years since I've used TomTom (reinstalled yesterday), so the behavior might have changed, but I've found that I ONLY see the Crazy Taxi arrow now if I manually create a waypoint (or perhaps if my toon dies, but I haven't died since I installed the addon).

Another thing I've found is that I cannot manually add waypoints to the world map without changing the addon settings. I have to do "/tomtom", expand the TomTom settings, and then change World Map > Create note modifier to Shift, and then SHIFT-RIGHT-CLICK on the map to create a waypoint. This causes the crazy taxi arrow to appear. I haven't found a way to make it work with quests yet, if that's still a thing it's supposed to do.
The map and POI integration are a bit tricky right now with the map and quest systems changing so dramatically. I haven't done an assessment of where they are right so I'm not perfectly sure.

I do remember someone reporting an issue with the world map click modifier and recall the default needing to change, but I believe that is still working for me (shift or control). Good reports, we'll need to look and understand the current status.

But the main functionality of the addon is being able to manually set a waypoint via /way, which should still work fine for most things. /cway (set a waypoint to your current location) can also be useful!
__________________
"There's only one thing that I know how to do well and I've often been told that you only can do what you know how to do well, and that's be you-- be what you're like-- be like yourself. And so I'm having a wonderful time, but I'd rather be whistling in the dark..."
Report comment to moderator  
Reply With Quote
Unread Yesterday, 05:25 PM  
Mazona
A Kobold Labourer
 
Mazona's Avatar

Forum posts: 0
File comments: 1
Uploads: 0
Re: TomTom not working since Shadowlands pre-patch

Originally Posted by essex23
So I have been using TomTom for a bit now...not long, but I really enjoyed having my nice, friendly little green arrow pointing me where I needed to go. But since the pre-patch...he seems to have gone AWOL. I think Sylvanas has done something dastardly to him because all my attempts to coax him out from his hiding hole are not working.
I've been trying to figure this one out today, and my feeling is that the current version of the AddOn (1.1.9) maybe doesn't fully work in the current version of WoW (9.0.2)? (Haven't tried any alpha or beta versions, if such exist.)

It has been years since I've used TomTom (reinstalled yesterday), so the behavior might have changed, but I've found that I ONLY see the Crazy Taxi arrow now if I manually create a waypoint (or perhaps if my toon dies, but I haven't died since I installed the addon).

Another thing I've found is that I cannot manually add waypoints to the world map without changing the addon settings. I have to do "/tomtom", expand the TomTom settings, and then change World Map > Create note modifier to Shift, and then SHIFT-RIGHT-CLICK on the map to create a waypoint. This causes the crazy taxi arrow to appear. I haven't found a way to make it work with quests yet, if that's still a thing it's supposed to do.
Last edited by Mazona : 12-01-20 at 05:28 PM.
Report comment to moderator  
Reply With Quote
Unread Yesterday, 10:20 AM  
Vuruba
A Kobold Labourer

Forum posts: 0
File comments: 57
Uploads: 0
Zone name SL?

Hello, I have the problem that the zone name does not work in the Shaodwlands. In the old worlds it works. What am I doing wrong:

/way Revendreth 51.12, 78.77
Last edited by Vuruba : 12-01-20 at 11:06 AM.
Report comment to moderator  
Reply With Quote
Unread 11-09-20, 03:46 PM  
Ludovicus
Premium Member
 
Ludovicus's Avatar
Premium Member

Forum posts: 0
File comments: 81
Uploads: 0
Re: Re: Re: Re: Re: TomTom not working since Shadowlands pre-patch

Originally Posted by essex23
It would be great if Ludovicus uploaded the Beta version here too, I don't have a Curse account and don't really want to make one.
Beta is here now too! I've got 60 messages back at Curse I have to go through before I make either the next beta or real release next.
__________________
Programmer on the Lam
Report comment to moderator  
Reply With Quote
Unread 11-09-20, 07:55 AM  
Cluey
A Fallenroot Satyr

Forum posts: 26
File comments: 92
Uploads: 0
Re: Re: Re: Re: Re: TomTom not working since Shadowlands pre-patch

Originally Posted by essex23
Well, I Googled "WoW TomTom Beta" and got to the Curse page where they had a file listed as "v70300-1.0.1-beta"....so I downloaded it and got a whole new set of error messages. lol
Well yeah you would, that's the version for WoW 7, which was Warlords of Draenor.

What was wrong with my instructions?
Report comment to moderator  
Reply With Quote
Unread 11-08-20, 08:57 AM  
essex23
A Murloc Raider
 
essex23's Avatar

Forum posts: 4
File comments: 6
Uploads: 0
Re: Re: Re: Re: TomTom not working since Shadowlands pre-patch

Originally Posted by Cluey
Originally Posted by essex23
According to my addon manager through Twitch, it says I am using 9.0.1 and that it is "up to date"


And only a C+? I thought it was a solid B+/A- lol
There's a difference between the game version and the addon version. Quite often there will be multiple addon versions for the same game version, which is what is happening now.

I don't use the Twitch client but from what I've read you need to find an option to get the alpha version, or you can just go to the addon page and download the zip file manually, that's what I do.
Looking at the addon page here it shows Version: v90001-1.1.5 under the little divider line, directly below the 9.0.1 which is in larger text on the same line the addon name is.
Looking at the Curseforge page it shows 25,309,669 Downloads Last Updated: Oct 26, 2020 Game Version: 9.0.1 under the addon title but on the RHS of the web page there are more details, the bottom part has a Recent files section which lists the version number for both the Retail and Classic versions.

Currently you need the Beta version, it's beta as it's still being tested. To get it you need to click the Files link/tab, which is next to the default tab labeled Description.
After you click that link it should show you details about the Main File and a bit further down will be a list under a Recent Files heading, it will look a bit like this and on the RHS of each line there's a download link.
Code:
Type 	Name 	 	Size 	 	Uploaded 	Game Version 	Downloads
B	v90001-1.1.7 	798.01 KB 	Oct 26, 2020 	9.0.1 		3,385 	
B	v90001-1.1.6 	798.03 KB 	Oct 19, 2020 	9.0.1 		2,890 	
R	v90001-1.1.5 	797.86 KB 	Oct 14, 2020 	9.0.1 		658,637
To use the latest version you're effectively becoming a tester, but at least then your feedback will be about the latest version.

It would be great if Ludovicus uploaded the Beta version here too, I don't have a Curse account and don't really want to make one.
Well, I Googled "WoW TomTom Beta" and got to the Curse page where they had a file listed as "v70300-1.0.1-beta"....so I downloaded it and got a whole new set of error messages. lol
Report comment to moderator  
Reply With Quote
Unread 11-08-20, 05:44 AM  
Cluey
A Fallenroot Satyr

Forum posts: 26
File comments: 92
Uploads: 0
Re: Re: Re: TomTom not working since Shadowlands pre-patch

Originally Posted by essex23
According to my addon manager through Twitch, it says I am using 9.0.1 and that it is "up to date"


And only a C+? I thought it was a solid B+/A- lol
There's a difference between the game version and the addon version. Quite often there will be multiple addon versions for the same game version, which is what is happening now.

I don't use the Twitch client but from what I've read you need to find an option to get the alpha version, or you can just go to the addon page and download the zip file manually, that's what I do.
Looking at the addon page here it shows Version: v90001-1.1.5 under the little divider line, directly below the 9.0.1 which is in larger text on the same line the addon name is.
Looking at the Curseforge page it shows 25,309,669 Downloads Last Updated: Oct 26, 2020 Game Version: 9.0.1 under the addon title but on the RHS of the web page there are more details, the bottom part has a Recent files section which lists the version number for both the Retail and Classic versions.

Currently you need the Beta version, it's beta as it's still being tested. To get it you need to click the Files link/tab, which is next to the default tab labeled Description.
After you click that link it should show you details about the Main File and a bit further down will be a list under a Recent Files heading, it will look a bit like this and on the RHS of each line there's a download link.
Code:
Type 	Name 	 	Size 	 	Uploaded 	Game Version 	Downloads
B	v90001-1.1.7 	798.01 KB 	Oct 26, 2020 	9.0.1 		3,385 	
B	v90001-1.1.6 	798.03 KB 	Oct 19, 2020 	9.0.1 		2,890 	
R	v90001-1.1.5 	797.86 KB 	Oct 14, 2020 	9.0.1 		658,637
To use the latest version you're effectively becoming a tester, but at least then your feedback will be about the latest version.

It would be great if Ludovicus uploaded the Beta version here too, I don't have a Curse account and don't really want to make one.
Report comment to moderator  
Reply With Quote
Unread 11-03-20, 11:31 AM  
essex23
A Murloc Raider
 
essex23's Avatar

Forum posts: 4
File comments: 6
Uploads: 0
Re: Re: TomTom not working since Shadowlands pre-patch

Originally Posted by Cluey
Originally Posted by essex23
So I have been using TomTom for a bit now...not long, but I really enjoyed having my nice, friendly little green arrow pointing me where I needed to go. But since the pre-patch...he seems to have gone AWOL. I think Sylvanas has done something dastardly to him because all my attempts to coax him out from his hiding hole are not working.

My last effort at calling him resulted in me getting this terrible note sent to me at the and of an arrow:


Code:
x1  TomTom\TomTom_POIIntegration.lua:77: attempt to call global 'GetQuestIndexForWatch' (a nil value)
Stack: [string "@TomTom\TomTom_POIIntegration.lua"]:77: in function <TomTom\TomTom_POIIntegration.lua:29>
[string "@TomTom\TomTom_POIIntegration.lua"]:154: in function <TomTom\TomTom_POIIntegration.lua:150>
Time: 2020/11/02 10:40:11 Index: 3/4
RealUI Version: 2.2.4
Locals:
map = 876
Is this some form of ransom that the Dark Lady and the Jailor have given to me? How can we overcome the forces of darkness and allow justice to prevail once again?
C+ for RP.

Which version are you using?
It's mostly working fine for me now but I had to grab the alpha version from Curse as Ludovicus hasn't uploaded it here yet.

-------------------------------------------------------------------------------------------------------

Ludovicus it's mostly working now with the v90001-1.1.7 alpha.
Some WQ ctrl+RMB or alt+RMB, which I've changed in the options, doesn't bring up an arrow.
It works for the hand in points for real quests and some of the world quests, I've not been able to work out what the difference is between the WQ which work and the ones which don't but I've not had much chance to specifically try and work that out. I always seem to end up rushing before daily reset so don't get a chance to solve problems.
According to my addon manager through Twitch, it says I am using 9.0.1 and that it is "up to date"


And only a C+? I thought it was a solid B+/A- lol
Report comment to moderator  
Reply With Quote
Unread 11-02-20, 11:53 PM  
Cluey
A Fallenroot Satyr

Forum posts: 26
File comments: 92
Uploads: 0
Re: TomTom not working since Shadowlands pre-patch

Originally Posted by essex23
So I have been using TomTom for a bit now...not long, but I really enjoyed having my nice, friendly little green arrow pointing me where I needed to go. But since the pre-patch...he seems to have gone AWOL. I think Sylvanas has done something dastardly to him because all my attempts to coax him out from his hiding hole are not working.

My last effort at calling him resulted in me getting this terrible note sent to me at the and of an arrow:


Code:
x1  TomTom\TomTom_POIIntegration.lua:77: attempt to call global 'GetQuestIndexForWatch' (a nil value)
Stack: [string "@TomTom\TomTom_POIIntegration.lua"]:77: in function <TomTom\TomTom_POIIntegration.lua:29>
[string "@TomTom\TomTom_POIIntegration.lua"]:154: in function <TomTom\TomTom_POIIntegration.lua:150>
Time: 2020/11/02 10:40:11 Index: 3/4
RealUI Version: 2.2.4
Locals:
map = 876
Is this some form of ransom that the Dark Lady and the Jailor have given to me? How can we overcome the forces of darkness and allow justice to prevail once again?
C+ for RP.

Which version are you using?
It's mostly working fine for me now but I had to grab the alpha version from Curse as Ludovicus hasn't uploaded it here yet.

-------------------------------------------------------------------------------------------------------

Ludovicus it's mostly working now with the v90001-1.1.7 alpha.
Some WQ ctrl+RMB or alt+RMB, which I've changed in the options, doesn't bring up an arrow.
It works for the hand in points for real quests and some of the world quests, I've not been able to work out what the difference is between the WQ which work and the ones which don't but I've not had much chance to specifically try and work that out. I always seem to end up rushing before daily reset so don't get a chance to solve problems.
Report comment to moderator  
Reply With Quote
Unread 11-02-20, 10:52 AM  
essex23
A Murloc Raider
 
essex23's Avatar

Forum posts: 4
File comments: 6
Uploads: 0
TomTom not working since Shadowlands pre-patch

So I have been using TomTom for a bit now...not long, but I really enjoyed having my nice, friendly little green arrow pointing me where I needed to go. But since the pre-patch...he seems to have gone AWOL. I think Sylvanas has done something dastardly to him because all my attempts to coax him out from his hiding hole are not working.

My last effort at calling him resulted in me getting this terrible note sent to me at the and of an arrow:


x1 TomTom\TomTom_POIIntegration.lua:77: attempt to call global 'GetQuestIndexForWatch' (a nil value)
Stack: [string "@TomTom\TomTom_POIIntegration.lua"]:77: in function <TomTom\TomTom_POIIntegration.lua:29>
[string "@TomTom\TomTom_POIIntegration.lua"]:154: in function <TomTom\TomTom_POIIntegration.lua:150>
Time: 2020/11/02 10:40:11 Index: 3/4
RealUI Version: 2.2.4
Locals:
map = 876
player = {
RotateDirection = function @SharedXML\Vector2D.lua:126
GetLength = function @SharedXML\Vector2D.lua:118
Normalize = function @SharedXML\Vector2D.lua:122
Dot = function @SharedXML\Vector2D.lua:106
GetLengthSquared = function @SharedXML\Vector2D.lua:114
GetXY = function @SharedXML\Vector2D.lua:77
OnLoad = function @SharedXML\Vector2D.lua:68
IsZero = function @SharedXML\Vector2D.lua:110
DivideBy = function @SharedXML\Vector2D.lua:90
x = 0.616456
y = 0.494232
Subtract = function @SharedXML\Vector2D.lua:98
Clone = function @SharedXML\Vector2D.lua:130
Cross = function @SharedXML\Vector2D.lua:102
ScaleBy = function @SharedXML\Vector2D.lua:86
SetXY = function @SharedXML\Vector2D.lua:81
IsEqualTo = function @SharedXML\Vector2D.lua:72
Add = function @SharedXML\Vector2D.lua:94
}
px = 0.616456
py = 0.494232
cvar = true
closest = nil
closestdist = Infinite
watchIndex = 1
(*temporary) = nil
(*temporary) = 1
(*temporary) = "attempt to call global 'GetQuestIndexForWatch' (a nil value)"
enableClosest = true
scanning = true
getQIDFromIndex = function @TomTom\TomTom_POIIntegration.lua:25
hbd = {
mapData = {}
GetAllMapIDs = function @nibRealUI\Libs\HereBeDragons\HereBeDragons-2.0.lua:333
UpdateCurrentPosition = function @nibRealUI\Libs\HereBeDragons\HereBeDragons-2.0.lua:252
callbacks = {}
GetPlayerZone = function @nibRealUI\Libs\HereBeDragons\HereBeDragons-2.0.lua:537
___DIIDO = {}
transforms = {}
GetLocalizedMap = function @nibRealUI\Libs\HereBeDragons\HereBeDragons-2.0.lua:317
eventFrame = <unnamed> {}
GetPlayerZonePosition = function @nibRealUI\Libs\HereBeDragons\HereBeDragons-2.0.lua:545
GetPlayerWorldPosition = function @nibRealUI\Libs\HereBeDragons\HereBeDragons-2.0.lua:525
GetZoneDistance = function @nibRealUI\Libs\HereBeDragons\HereBeDragons-2.0.lua:469
GetUnitWorldPosition = function @nibRealUI\Libs\HereBeDragons\HereBeDragons-2.0.lua:513
GetWorldCoordinatesFromZone = function @nibRealUI\Libs\HereBeDragons\HereBeDragons-2.0.lua:345
GetWorldDistance = function @nibRealUI\Libs\HereBeDragons\HereBeDragons-2.0.lua:455
RegisterCallback = function @Ace3\CallbackHandler-1.0\CallbackHandler-1.0.lua:90
GetWorldCoordinatesFromAzerothWorldMap = function @nibRealUI\Libs\HereBeDragons\HereBeDragons-2.0.lua:360
UnregisterCallback = function @Ace3\CallbackHandler-1.0\CallbackHandler-1.0.lua:153
GetZoneSize = function @nibRealUI\Libs\HereBeDragons\HereBeDragons-2.0.lua:324
worldMapData = {}
GetZoneCoordinatesFromWorld = function @nibRealUI\Libs\HereBeDragons\HereBeDragons-2.0.lua:377
TranslateZoneCoordinates = function @nibRealUI\Libs\HereBeDragons\HereBeDragons-2.0.lua:432
GetWorldVector = function @nibRealUI\Libs\HereBeDragons\HereBeDragons-2.0.lua:490
GetAzerothWorldMapCoordinatesFromWorld = function @nibRealUI\Libs\HereBeDragons\HereBeDragons-2.0.lua:396
}
lastWaypoint = nil



Is this some form of ransom that the Dark Lady and the Jailor have given to me? How can we overcome the forces of darkness and allow justice to prevail once again?
Report comment to moderator  
Reply With Quote
Unread 10-28-20, 10:00 AM  
Cluey
A Fallenroot Satyr

Forum posts: 26
File comments: 92
Uploads: 0
Re: Re: Still getting 9.0 errors.

Originally Posted by Ludovicus
Originally Posted by Cluey
Hi Ludovicus,
I grabbed the v90001-1.1.6 from Curseforge, I don't have an account there so I can't provide feedback there and couldn't find a Github.

If I change GetQuestLogIndexByID to C_QuestLog.GetQuestLogIndexByID, as that was a 9.0.1 change, the error changes to: ...
At which point I'm out of my depth and can't trouble shoot further.
BTW: The correct function is C_QuestLog.GetLogIndexForQuestID.
That's above my pay grade. ;-)

I did a search on wow.gamepedia.com and that was the closest match, interestingly I actually have this page open in another tab.
So I was close!
Report comment to moderator  
Reply With Quote
Unread 10-25-20, 11:16 AM  
Ludovicus
Premium Member
 
Ludovicus's Avatar
Premium Member

Forum posts: 0
File comments: 81
Uploads: 0
Re: Still getting 9.0 errors.

Originally Posted by Cluey
Hi Ludovicus,
I grabbed the v90001-1.1.6 from Curseforge, I don't have an account there so I can't provide feedback there and couldn't find a Github.

If I change GetQuestLogIndexByID to C_QuestLog.GetQuestLogIndexByID, as that was a 9.0.1 change, the error changes to: ...
At which point I'm out of my depth and can't trouble shoot further.
BTW: The correct function is C_QuestLog.GetLogIndexForQuestID.
__________________
Programmer on the Lam
Report comment to moderator  
Reply With Quote
Unread 10-24-20, 05:58 AM  
Ludovicus
Premium Member
 
Ludovicus's Avatar
Premium Member

Forum posts: 0
File comments: 81
Uploads: 0
Re: Still getting 9.0 errors.

Thanks for the feedback and the most useful comment I have gotten in awhile.
I'll make some adjustments after my AH duties this morning and come up with another beta.
I'll post it here too to make it easier for you.
Originally Posted by Cluey
Hi Ludovicus,
I grabbed the v90001-1.1.6 from Curseforge, I don't have an account there so I can't provide feedback there and couldn't find a Github.
__________________
Programmer on the Lam
Report comment to moderator  
Reply With Quote
Unread 10-23-20, 11:49 PM  
Cluey
A Fallenroot Satyr

Forum posts: 26
File comments: 92
Uploads: 0
Still getting 9.0 errors.

Hi Ludovicus,
I grabbed the v90001-1.1.6 from Curseforge, I don't have an account there so I can't provide feedback there and couldn't find a Github.
I've changed the Create note modifier key to Alt as Blizzards new system is using the Ctrl modifier now. You should probably make Alt the default now unless you can hijack their call to work with both.
Making it work with both would be the most desirable option and probably eliminate many questions/comments/bug reports going forward.
By that I mean if players can Ctrl+RMB a quest indicator on the map and the TomTom arrow pops up and the Blizzard one works too.
The Blizzard one is limited by the zone you're in and only shows distance, while TomTom is happy to give you distance and it gives a time estimate to any point on the same continent.

With the modifier key change Alt+RMB on a world quest isn't giving an arrow, I'm resorting to making a waypoint as near to it as I can, or finding it in my Broker_Worldquest list. That integration is still adding them to the arrow although it only adds one, choosing another replaces the previous one. Not sure which mod is doing that but it isn't a show stopper, I can play around that.

If it's a normal quest I get this error:
Code:
1x TomTom\TomTom_POIIntegration.lua:178: attempt to call global 'GetQuestLogIndexByID' (a nil value)
[string "@TomTom\TomTom_POIIntegration.lua"]:178: in function <TomTom\TomTom_POIIntegration.lua:153>
[string "@TomTom\TomTom_POIIntegration.lua"]:241: in function <TomTom\TomTom_POIIntegration.lua:240>
[string "=[C]"]: in function `QuestPOIButton_OnClick'
[string "@Blizzard_SharedMapDataProviders\QuestDataProvider.lua"]:241: in function `OnMouseClickAction'
[string "@Blizzard_MapCanvas\MapCanvas_DataProviderBase.lua"]:157: in function `OnClick'
[string "@Blizzard_MapCanvas\Blizzard_MapCanvas.lua"]:146: in function <...aceBlizzard_MapCanvas\Blizzard_MapCanvas.lua:143>
If I change GetQuestLogIndexByID to C_QuestLog.GetQuestLogIndexByID, as that was a 9.0.1 change, the error changes to:
Code:
1x TomTom\TomTom_POIIntegration.lua:178: attempt to call field 'GetQuestLogIndexByID' (a nil value)
[string "@TomTom\TomTom_POIIntegration.lua"]:178: in function <TomTom\TomTom_POIIntegration.lua:153>
[string "@TomTom\TomTom_POIIntegration.lua"]:241: in function <TomTom\TomTom_POIIntegration.lua:240>
[string "=[C]"]: in function `QuestPOIButton_OnClick'
[string "@Blizzard_SharedMapDataProviders\QuestDataProvider.lua"]:241: in function `OnMouseClickAction'
[string "@Blizzard_MapCanvas\MapCanvas_DataProviderBase.lua"]:157: in function `OnClick'
[string "@Blizzard_MapCanvas\Blizzard_MapCanvas.lua"]:146: in function <...aceBlizzard_MapCanvas\Blizzard_MapCanvas.lua:143>
At which point I'm out of my depth and can't trouble shoot further.
Report comment to moderator  
Reply With Quote
Unread 10-23-20, 03:15 PM  
Barleduq
Premium Member
 
Barleduq's Avatar
Premium Member

Forum posts: 133
File comments: 756
Uploads: 0
Re: Re: Update here, please?

Woo! Thank you!!!!!
-Barleduq


Originally Posted by Ludovicus
Originally Posted by Barleduq
Just a reminder/request to please update here on wowinterface, also?
-Barleduq
Updated. Sorry!
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: