Quantcast
Download
(310 Kb)
Download
Updated: 09-07-19 11:50 PM
Pictures
File Info
Compatibility:
Rise of Azshara (8.2.0)
Updated:09-07-19 11:50 PM
Created:08-07-09 11:52 PM
Downloads:25,901
Favorites:117
MD5:
Categories:Raid Mods, Healers, Unit Mods
8.2.0

Aptechka  Popular! (More than 5000 hits)

Version: 8.2.17
by: d87 [More]

Aptechka is a raid frames addon.

THIS IS LIVE VERSION

Notable features:
- Autoscaling based on role/raid size.
- Debuff icons with a blacklist
- Preconfigured for all healing classes with a variety of indicator types
- Incoming casts display
- Spell Locks as debuffs
- Debuff ordering
- Feedback indicators for smart aoe heals

Console command: /apt
github







In case anyone was still using userconfigs, here's the
new example config with PostFrameUpdate hook

### 8.2.16:

- fixed possible frame glitches on login
- fixed Growth not setting correctly on login

### 8.2.15:

- fixed issue with arcane mages mana doing weird things

### 8.2.14:

- Priest config update

### 8.2.13:

- A lot of internal changes to frame contruction
- Removed inverted colors setting
- Instead you now can switch between reverse filling of the health bar
- Color multiplier settings for fg/bg/name
- Name outline setting
- Bugfixes

### 8.2.12:

- Targeted Casts feature
- bugfixes

### 8.2.11:

- Removed old skin support
- Added Aptechka.PostFrameUpdate for skinning

### 8.2.9:

- fixed error caused by added from GUI spells

### 8.2.8:

- increased aura handling performance

### 8.2.7:

- fixed LoS warning
- fixed missing health formatting on low level characters
- added heal absorb bar
- not showing missing spell indicators if they aren't learned yet

### 8.2.6:

- Workaround for 8.1 SGH missing units bug, but this time for raids

### 8.2.5:

- Stagger indicator
- Other active mitigation icons
- Blessing of Sacrifice icon
- Font is now adjustable
- Debuff size is now adjustable
- Hopefully fixed summon text getting stuck

### 8.2.4:

- Incoming Summon indicator
- disabled LibCLH

### 8.2.3:

- fixed role icons

### 8.2.2:

- minor bugfixes
- added blacklist info to GUI
- added Dampening to blacklist

### 8.2.1:

- fixed the issue with UnitButtons not appearing until out of combat
- blacklisted nazjatar debuffs

### 8.2.0:

- Better hiding blizzard raid frames
- Added spell ranks support
- Classic compatibility
- Added Standstill and Vitality Conduit

### 8.1.5:

- proper fix for 8.1 "Unknown" units bug

### 8.1.2:

- Shift-RightClick now toggles menu
- Option to disable tooltips completely
Archived Files (56)
File Name
Version
Size
Author
Date
8.2.16
310kB
d87
09-04-19 02:35 AM
8.2.15
310kB
d87
08-26-19 07:55 AM
8.2.14
310kB
d87
08-25-19 04:26 AM
8.2.12
310kB
d87
08-18-19 09:19 PM
8.2.11
305kB
d87
08-10-19 10:55 AM
8.2.10
305kB
d87
08-08-19 01:14 PM
8.2.9
305kB
d87
08-08-19 09:37 AM
8.2.8
305kB
d87
08-06-19 01:40 PM
8.2.7
305kB
d87
07-29-19 05:20 AM
8.2.6
302kB
d87
07-22-19 02:31 AM
8.2.5
302kB
d87
07-19-19 10:08 AM
8.2.4
304kB
d87
07-11-19 12:25 PM
8.2.3
304kB
d87
07-04-19 01:22 AM
8.2.2
304kB
d87
07-02-19 06:58 AM
8.2.1
307kB
d87
06-26-19 11:33 PM
8.2.0
307kB
d87
06-25-19 06:53 AM
8.1.5
304kB
d87
04-13-19 04:14 AM
8.1.3
304kB
d87
02-13-19 05:19 AM
8.1.2
304kB
d87
12-31-18 09:56 PM
8.1.1
304kB
d87
12-15-18 10:25 AM
8.1.0
303kB
d87
12-11-18 01:55 AM
8.0.12
303kB
d87
09-27-18 01:29 PM
8.0.11
303kB
d87
09-27-18 12:39 PM
8.0.10
303kB
d87
09-20-18 05:51 AM
8.0.9
301kB
d87
09-15-18 02:08 PM
8.0.8
301kB
d87
09-14-18 09:19 AM
8.0.7
301kB
d87
09-13-18 10:09 PM
8.0.6
281kB
d87
09-03-18 10:38 AM
8.0.5
280kB
d87
08-19-18 12:58 AM
8.0.4
280kB
d87
07-30-18 05:51 AM
8.0.3
278kB
d87
07-22-18 10:02 AM
8.0.2
279kB
d87
07-17-18 10:18 PM
8.0.1
279kB
d87
07-17-18 07:28 AM
7.3.9
270kB
d87
04-09-18 04:44 PM
7.3.8
270kB
d87
10-29-17 05:14 AM
7.3.4
176kB
d87
10-26-17 01:33 PM
7.3.3
182kB
d87
10-05-17 03:40 PM
7.3.2
182kB
d87
09-26-17 06:07 AM
7.3.1
182kB
d87
08-31-17 10:59 AM
2.5.6a
181kB
d87
06-09-17 07:46 PM
2.5.5a
181kB
d87
10-25-16 04:51 AM
2.5.4
186kB
d87
10-05-16 12:13 PM
2.5.3a
212kB
d87
08-30-16 08:55 PM
2.5.2
206kB
d87
08-07-16 11:20 AM
2.5.1
206kB
d87
08-01-16 08:27 AM
2.4.2
199kB
d87
11-16-14 12:49 PM
2.4.1
199kB
d87
11-05-14 11:43 AM
2.4.0
173kB
d87
10-14-14 11:20 AM
2.3.1
163kB
d87
05-22-13 07:39 PM
2.3.0
163kB
d87
04-07-13 01:00 AM
2.2.3
159kB
d87
11-23-12 10:03 AM
2.2.1
158kB
d87
10-14-12 06:06 AM
2.2.0
158kB
d87
08-28-12 08:09 AM
2.1.10 [50000]
151kB
d87
08-19-12 10:57 AM
2.1.9 [50000]
151kB
d87
07-03-12 05:14 AM
2.1.8 [50000]
151kB
d87
07-01-12 07:23 AM


Post A Reply Comment Options
Unread 08-09-19, 06:00 PM  
d87
A Flamescale Wyrmkin
 
d87's Avatar
AddOn Author - Click to view AddOns

Forum posts: 136
File comments: 585
Uploads: 38
Originally Posted by jessica
also do I have to download this frame.lua specially for me? everytime I update?
No, it'll be fine from now on, I just didn't want to do a full update. There was nothing wrong your config, just a bug with userconfigs in general
Last edited by d87 : 08-09-19 at 06:00 PM.
Report comment to moderator  
Reply With Quote
Unread 08-09-19, 11:56 AM  
jessica
A Cyclonian

Forum posts: 41
File comments: 137
Uploads: 0
Originally Posted by d87
Originally Posted by jessica
ill just report errors that I find with BugSack.
Pffft, It's something with userconfig that makes heal absorb bar throw this error.
You can see for yourself if you have a disc priest with shadow covenant.
But i have no idea what it is exactly. Disable you config for now if it's too annoying

EDIT: i found it, download this https://raw.githubusercontent.com/rg...ster/frame.lua and replace the one in addon folder
Thanks, what was it? is it a problem with my userconfig again? by the way, this fixed the error but it changed my texture and backdrop of the whole grid, but nonetheless I like the change, no problem for me.

also do I have to download this frame.lua specially for me? everytime I update?
Report comment to moderator  
Reply With Quote
Unread 08-09-19, 08:58 AM  
d87
A Flamescale Wyrmkin
 
d87's Avatar
AddOn Author - Click to view AddOns

Forum posts: 136
File comments: 585
Uploads: 38
Originally Posted by jessica
ill just report errors that I find with BugSack.
Pffft, It's something with userconfig that makes heal absorb bar throw this error.
You can see for yourself if you have a disc priest with shadow covenant.
But i have no idea what it is exactly. Disable you config for now if it's too annoying

EDIT: i found it, download this https://raw.githubusercontent.com/rgd87/Aptechka/master/frame.lua and replace the one in addon folder
Last edited by d87 : 08-09-19 at 09:11 AM.
Report comment to moderator  
Reply With Quote
Unread 08-09-19, 08:30 AM  
jessica
A Cyclonian

Forum posts: 41
File comments: 137
Uploads: 0
ill just report errors that I find with BugSack.

26x Aptechka\frame.lua:826: attempt to perform arithmetic on local 'frameLength' (a nil value)
Aptechka\frame.lua:826: in function `UpdatePosition'
Aptechka\frame.lua:851: in function `SetValue'
Aptechka\[email protected]@.lua:828: in function `?'
Aptechka\[email protected]@.lua:7: in function <Aptechka\Aptechka.lua:6>

Locals:
InCombatSkipped
Report comment to moderator  
Reply With Quote
Unread 07-23-19, 01:43 PM  
Xully
An Aku'mai Servant

Forum posts: 33
File comments: 174
Uploads: 0
Originally Posted by d87
Sort of fixed that in version 8.2.6. Turned out It's actually an extension of the same wow bug as "Unknown" units, only worse. But basically now 3 seconds after joining a raid, it'll refresh to get the missing units. Unless you're in combat, then it'll happen only after you're out of it
Thank you very much, it is indeed fixed.
Report comment to moderator  
Reply With Quote
Unread 07-23-19, 10:45 AM  
d87
A Flamescale Wyrmkin
 
d87's Avatar
AddOn Author - Click to view AddOns

Forum posts: 136
File comments: 585
Uploads: 38
1) When joining a raid group for instance, it takes good 1 to 2 mins until all raid members will be shown, sometimes I join and only I and the raid-leader are shown, takes long time until the rest shown in grid.
Sort of fixed that in version 8.2.6. Turned out It's actually an extension of the same wow bug as "Unknown" units, only worse. But basically now 3 seconds after joining a raid, it'll refresh to get the missing units. Unless you're in combat, then it'll happen only after you're out of it
Report comment to moderator  
Reply With Quote
Unread 07-19-19, 10:07 AM  
Xully
An Aku'mai Servant

Forum posts: 33
File comments: 174
Uploads: 0
Originally Posted by d87
Code:
1) When joining a raid group for instance, it takes good 1 to 2 mins until all raid members will be shown, sometimes I join and only I and the raid-leader are shown, takes long time until the rest shown in grid.
That should've been fixed 2 days after 8.2 release. Does that still happen on newer versions? I haven't noticed anything like that

Code:
2) There's a new word "Accepted" in green, I think its for the summons, more often than not it gets stuck there and never go away, until a /reload ui.
I've only seen this once, and not sure why this happens. Does it gets stuck while you're in the loading screen?
I have latest verion from curse, don't know if thats the most recent update.

And it does happen at any time, but not always, for instance today in a raid it happened with the DK, but didn't happen with another shaman, but then later on it happened on my frame when they summoned me, so its random.
Report comment to moderator  
Reply With Quote
Unread 07-19-19, 09:35 AM  
d87
A Flamescale Wyrmkin
 
d87's Avatar
AddOn Author - Click to view AddOns

Forum posts: 136
File comments: 585
Uploads: 38
Code:
1) When joining a raid group for instance, it takes good 1 to 2 mins until all raid members will be shown, sometimes I join and only I and the raid-leader are shown, takes long time until the rest shown in grid.
That should've been fixed 2 days after 8.2 release. Does that still happen on newer versions? I haven't noticed anything like that

Code:
2) There's a new word "Accepted" in green, I think its for the summons, more often than not it gets stuck there and never go away, until a /reload ui.
I've only seen this once, and not sure why this happens. Does it gets stuck while you're in the loading screen?
Last edited by d87 : 07-19-19 at 09:55 AM.
Report comment to moderator  
Reply With Quote
Unread 07-19-19, 09:05 AM  
Xully
An Aku'mai Servant

Forum posts: 33
File comments: 174
Uploads: 0
Hi, Ive been having two issues since 8.2

1) When joining a raid group for instance, it takes good 1 to 2 mins until all raid members will be shown, sometimes I join and only I and the raid-leader are shown, takes long time until the rest shown in grid.

2) There's a new word "Accepted" in green, I think its for the summons, more often than not it gets stuck there and never go away, until a /reload ui.

Other than that, love the addon mate.
Report comment to moderator  
Reply With Quote
Unread 05-22-19, 07:28 PM  
d87
A Flamescale Wyrmkin
 
d87's Avatar
AddOn Author - Click to view AddOns

Forum posts: 136
File comments: 585
Uploads: 38
Originally Posted by strickland
Originally Posted by d87
rollback to wowi version and dont update from github until 8.2 release. But the issue is that you're getting an erro because your installation is missing 2 new libraries, and libraries only come packaged with official releases
What you mean by rollback to wowi version? Do you mean to redownload the 8.1.5 and delete the one that I got from github?
yes
Report comment to moderator  
Reply With Quote
Unread 05-22-19, 04:41 PM  
strickland
An Aku'mai Servant

Forum posts: 36
File comments: 192
Uploads: 0
Originally Posted by d87
rollback to wowi version and dont update from github until 8.2 release. But the issue is that you're getting an erro because your installation is missing 2 new libraries, and libraries only come packaged with official releases
What you mean by rollback to wowi version? Do you mean to redownload the 8.1.5 and delete the one that I got from github?
Report comment to moderator  
Reply With Quote
Unread 05-22-19, 11:59 AM  
d87
A Flamescale Wyrmkin
 
d87's Avatar
AddOn Author - Click to view AddOns

Forum posts: 136
File comments: 585
Uploads: 38
rollback to wowi version and dont update from github until 8.2 release. But the issue is that you're getting an erro because your installation is missing 2 new libraries, and libraries only come packaged with official releases
Last edited by d87 : 05-22-19 at 12:01 PM.
Report comment to moderator  
Reply With Quote
Unread 05-22-19, 11:27 AM  
strickland
An Aku'mai Servant

Forum posts: 36
File comments: 192
Uploads: 0
I updated from github and now the addon doesn't show up when loaded, its like I don't have it
Report comment to moderator  
Reply With Quote
Unread 02-13-19, 10:16 PM  
d87
A Flamescale Wyrmkin
 
d87's Avatar
AddOn Author - Click to view AddOns

Forum posts: 136
File comments: 585
Uploads: 38
Originally Posted by strickland
Cheers for the update, curious to know why is it updated here but not on github?
well it sort of was, but if you straight up push a tag, then it doesn't update master
Report comment to moderator  
Reply With Quote
Unread 02-13-19, 04:28 PM  
strickland
An Aku'mai Servant

Forum posts: 36
File comments: 192
Uploads: 0
Cheers for the update, curious to know why is it updated here but not on github?
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump:

Support AddOn Development!

You have just downloaded by the author . If you like this AddOn why not consider supporting the author? This author has set up a donation account. Donations ensure that authors can continue to develop useful tools for everyone.