Quantcast
R
(17Kb)
Download
Updated: 02-25-21 11:36 AM
C
(17kB)
Download
Updated: 02-25-21 11:36 AM
Pictures
File Info
Compatibility:
Classic Patch (1.13.6)
Updated:02-25-21 11:36 AM
Created:02-25-21 07:18 AM
Downloads:62
Favorites:0
MD5:
Categories:Map, Coords, Compasses, Classic - General

TomTom group member arrow

Version: v1.16.3, Classic: v1.16.3
by: datagutten [More]

TomTom group member arrow
A TomTom Crazy Arrow will point and show distance to your fellow players in same party or raid as you. This only works in the open world, Blizzard does not allow positioning inside dungeons and raids.

This is a continuation of the abandoned plugin TomTomTargetArrow

Dependencies
As the name indicates, TomTom must be installed for this addon to work.

HereBeDragons is used to aquire player positions and do distance calculations, but since TomTom also depends on it, there is no need to install it separately.

Slash commands

Code:
/ttta stick
will stick to your current target.

Code:
/ttta unstick
will clear the sticky target and track the current target again.

TomTom group member arrow
v1.16.3 (2021-02-25)
Full Changelog Previous Releases
  • Add separate travis jobs for retail and classic
  • Do not remove WowInterface token
  • Add WoWInterface id
Optional Files (0)


Archived Files (1)
File Name
Version
Size
Author
Date
1.16.2
17kB
datagutten
02-25-21 07:18 AM


Post A Reply Comment Options
Unread 02-25-21, 11:49 PM  
myrroddin
A Pyroguard Emberseer
 
myrroddin's Avatar
AddOn Author - Click to view AddOns

Forum posts: 1152
File comments: 219
Uploads: 17
From the project description: HereBeDragons

HereBeDragons is used to aquire player positions and do distance calculations, but since TomTom also depends on it, there is no need to install it separately.
I assume this addon ships with HBD? If it doesn't, that could lead to errors during loading, as WoW will complain about missing libraries. You cannot depend on TomTom shipping with HBD; this addon must also ship with the library. In fact, this addon should also ship with LibStub and, if HBD requires it, CallbackHandler-1.0 as well.

The point being: any addon that uses libraries must ship with the libraries, even if those same libraries also ship with other addons.

Beyond that, yes, correct, insofar as the user does not need to install HereBeDragons as an addon itself.
Last edited by myrroddin : 02-25-21 at 11:51 PM.
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: