WoWInterface

WoWInterface (https://www.wowinterface.com/forums/index.php)
-   PTR General Discussion (https://www.wowinterface.com/forums/forumdisplay.php?f=172)
-   -   Updated version(s) of BugSack, !BugGrabber, ViragDevTool (https://www.wowinterface.com/forums/showthread.php?t=56184)

bsmorgan 04-27-18 10:31 AM

Updated version(s) of BugSack, !BugGrabber, ViragDevTool
 
If anyone has figured out how to get any of these addons working, can you please let us know. I've got enough on my plate to get Skillet working without having to find / learn new debugging tools as well :)

Seerah 04-27-18 11:24 AM

BugGrabber/BugSack were working fine for me the other night. Did something change?

VincentSDSH 04-27-18 07:05 PM

I've got updated versions, they're working fine on live for me. Had to tinker for the Beta but it was just a matter of changed api calls in the AceComm lib.

Maybe post the problem you're seeing?

Fizzlemizz 04-27-18 07:22 PM

The last Twitch BugSack DL for Beta included a fix for the AceCom libraries... but I renamed my "fixed" version first. :)

bsmorgan 04-27-18 07:35 PM

With BugGrabber and BugSack enabled I get a Lua Warning popup with:

Message: (null)
Time: Fri Apr 27 19:23:32 2018
Count: 5

I'm not sure if they are working because I managed to modify Skillet into an infinite loop :mad:

I'll report back after I back up to something that was at least giving error messages :D

bsmorgan 04-27-18 07:37 PM

With ViragDevTool enabled I get a Lua Warning popup with:

Message: Couldn't find inherited node: ViragDevToolOptionsToggleButton
Time: Fri Apr 27 19:36:10 2018
Count: 4

VincentSDSH 04-27-18 11:09 PM

I've got warnings turned on in beta and load clean, so whatever it is tossing up the warnings, I don't think it's the bug-twins. Did you have warnings turned off before?

Fizzlemizz 04-27-18 11:33 PM

Those two messages look like they are comming from the (as far as I can tell) new Blizzard error popup.

I've had Null come up before and it went away when I fixed other errors. The last one would imply that the ViragDevToolOptionsToggleButton template doesn't exist which would indicate a bug with ViragDevTools (a frame inheriting a template they've since deleted).

The Blizzard report is much more vigilant about templates existing/being duplicated and files listed in .toc and include .xml files existing (even commented out ones as it doesn't seem to check and ignore the -- anymore :mad:)

lightspark 04-28-18 02:02 AM

I'm using BugSack in beta, to make it work you need to updated embedded AceComm-3.0. You can get it from the latest Ace3's alpha release. It may or may not help you w/ other bug reporting addons, if you're getting this error:

Code:

Message: (null)
Time: Fri Apr 27 19:23:32 2018
Count: 5


bsmorgan 04-28-18 06:22 AM

The ACE3 alpha solved the bugsack / buggrabber issue and the viragdevtool error was, in fact, an error. I fixed it by changing the reference ViragDevToolOptionsToggleButton to ViragDevToolButtonTemplate in ViragDevTool.xml

Good news and bad news... I fixed the infinite loop error in Skillet, but its not throwing any errors so I can't verify that bugsack / buggrabber are working! :D

I'm sure that will change (errors in Skillet) but they will be difficult to find as all my template 110s have skill level(s) of 1 and I'm not sure I'll spend my beta time leveling professions.

Fizzlemizz 04-28-18 09:54 AM

They should be enabling character copies in the not too distant future so you will get plenty of time to test on one or more of your current characters.


All times are GMT -6. The time now is 07:24 PM.

vBulletin © 2020, Jelsoft Enterprises Ltd
© 2004 - 2020 MMOUI