WoWInterface

WoWInterface (https://www.wowinterface.com/forums/index.php)
-   AddOn Help/Support (https://www.wowinterface.com/forums/forumdisplay.php?f=3)
-   -   miirGui error (https://www.wowinterface.com/forums/showthread.php?t=46933)

Léthalvenom 07-25-13 01:52 AM

miirGui error
 
Hi guys.in patch 5.2 i never had problems with this addon but i quitted WoW for 7 months. Now in patch 5.3 i m getting an error message when entering combat. Looked at the author for help but people with the same problem didn t get an answer there.
Maybe some one is capable of helping me out. This is the message i m getting:

Code:

[ADDON_ACTION_BLOCKED] AddOn "miirGui" tried to call the protected function "SecondaryProfession4SpellButtonRight:Show()".
!BugGrabber-r193-release\BugGrabber.lua:587: in function <!BugGrabber\BugGrabber.lua:587>
<in C code>
miirGui-2.1.9\core.lua:511: in function <miirGui\core.lua:444>
<in C code>
FrameXML\SpellBookFrame.lua:1078: in function "SpellBook_UpdateProfTab"
FrameXML\SpellBookFrame.lua:160: in function <FrameXML\SpellBookFrame.lua:139>

Thanx in advance

Phanx 07-25-13 01:50 PM

Without seeing your code -- your actual code, and all of it -- there's no way anyone can possibly help you with a taint problem. Post a link to your addon's download page, or attach the files to your post, or use a paste service with a separate paste for each file.

Seerah 07-25-13 03:54 PM

psst - they're not the author of the addon ;)

That said... OP: are you using the version updated for 5.3?

Phanx 07-26-13 01:30 AM

Doesn't matter who wrote it... anyone can post a link to its download page, or post the code they're working with. :p

Léthalvenom 07-26-13 03:31 AM

Quote:

Originally Posted by Seerah (Post 281562)
That said... OP: are you using the version updated for 5.3?

Yes thats the first thing i always do. Checking for updates on all add-ons. I am using the 5.3 version.
Also i tried deleting all and reinstall it clean,didn t work.
(PS:while updating i couldn t find cael nameplates anymore,nothing of caellian as a matter of fact :confused: what happened with him?)
Well some one gave me another answer on the authors page here.
Quote:

Originally Posted by ComputerNerd
That message typically associated with Ace3 addons is often incorrectly attributing any Ace3 addon as being the cause.
If you disabled that addon it would simply happen again with another one, and then another one named.
Some say the fault is with Blizzard, some say it is with Ace3.It is not a MiirGui problem.

This is the downloadpage Phanx
http://www.wowinterface.com/download...Pack-Blue.html

So gues nothing we can do about it... And stay playing with a load of errors :(

def9 07-27-13 12:41 PM

Quote:

Originally Posted by Léthalvenom (Post 281585)
(PS:while updating i couldn t find cael nameplates anymore,nothing of caellian as a matter of fact :confused: what happened with him?)

All cael mods including the full ui, ouf unit frames, etc were removed about a month ago now by the author. I've never seen a post about why either but my guess is real life has crept in and they have no time to continue working on the addon(s).

Léthalvenom 07-31-13 04:25 AM

Sad that such a name left the community and didn t even gave others the chance to keep his work alive :(
Also too bad no one really has a solution for my error problem...

Phanx 07-31-13 04:35 PM

It's a taint error. It means some addon you are using is touching something it shouldn't be touching. You can try turning on detailed taint logging (type "/console taintlog 2" in-game), wait for the error to happen, then log out and wade through the billions of messages in World of Warcraft > Logs > taint.log, or you can try to reproduce the error with each addon installed individually. There's no way for anyone but you to figure out which of your however-many addons is causing the problem.

Also, whoever told you that error was related to Ace3 didn't know what they are talking about. Taint is not related to any specific library, and no Ace3 library itself causes taint. The Blizzard taint reporter is basically worthless, and essentially picks an addon at random to blame when taint breaks something. If you disabled miirGui, you'd just see the same error blaming some other addon.

Léthalvenom 08-03-13 05:33 AM

Ty again Phanx. I have the log now. Stupid question maybe but would u be so kind to help me understand it? Or what to look for?

Phanx 08-03-13 08:55 PM

Well, essentially you're looking for any lines that mention variables that aren't variables created by addons. Ignore the "global variable tained" lines for now. Once you find an interesting line, work your way back toward the top of the log through any/all of the "global variable tainted" lines mentioning the same variable, to see which addon(s) actually caused the taint. From there, it may or may not be obvious what the problem is and how to solve it.

However, if you can narrow down which addon is causing the problem, you should absolutely do that before you wade through 100mb of taint logs to see how it's causing the problem. Try to identify when the in-game error appears, and find a way to reproduce those conditions. For example, if the error always happens when you open your bags in combat, you can easily test it at a training dummy. Disable half your addons and go test. If the error doesn't appear, disable those addons, enable the other half, and test again. If the error does appear, disable half the enabled addons and test again. Continue this process until you narrow it down to a single addon.

Edit:
If you post your taint.log file here, someone might be willing to look at it for you, but that someone won't be me, sorry.

Léthalvenom 08-04-13 05:11 AM

Well i did some digging and its defo miirGui causing it. I have made a macro for popping cd's. Soon as i enter combat and pop that macro the error appears.
And apparently its always because of this :
Code:

An action was blocked in combat because of taint from miirGui - SecondaryProfession4SpellButtonRight:Show()


All times are GMT -6. The time now is 10:44 AM.

vBulletin © 2020, Jelsoft Enterprises Ltd
© 2004 - 2020 MMOUI