WoWInterface

WoWInterface (https://www.wowinterface.com/forums/index.php)
-   nUI: Technical Support (https://www.wowinterface.com/forums/forumdisplay.php?f=92)
-   -   Questhelper 5.0.5.26r & nUI+ (https://www.wowinterface.com/forums/showthread.php?t=45689)

Insidious93 01-18-13 06:32 PM

Questhelper 5.0.5.26r & nUI+
 
I searched the forums to find a near 3 year old post, so I would like to ask here since I am having issues, does the current build work? If so, what is required to make it work. I have simply installed the addon via curse, WoW accepts it as a loaded addon, but I cannot get it to load up. I'm leveling alts, and prior to switching to this today it was a very helpful tool.

Thanks in advance for any support! So far, I am really enjoying your work on this.

spiel2001 01-18-13 07:19 PM

I'm not aware of any conflicts between Quest Helper and nUI. They have always played well together to the best of my knowledge.... though I have not used Quest Helper in quite some time now.

Insidious93 01-18-13 08:21 PM

I wouldnt have either. No error messages come up, nor anything negative with the UI. You can even bring up QH command line commands. But for whatever reason it will not work. I'll keep messing with it some more. If you find anything let me know, I will do the same if I find a solution.

Insidious93 01-18-13 08:33 PM

Ok, opening the menu, then interface, then addons this error was generated when I clicked on QH.

Lua Error
Message: ...lper\libs\AceGUI-3.0\widgets\AceGUIWidget-Button.lua:66: CreateFrame(): Couldn't find inherited node "UIPanelButtonTemplate2"
Time: 01/18/13 21:27:56
Count: 1
Stack: (tail call): ?
[C]: ?
...lper\libs\AceGUI-3.0\widgets\AceGUIWidget-Button.lua:66: in function `?'
...ce\AddOns\QuestHelper\libs\AceGUI-3.0\AceGUI-3.0.lua:136: in function <...ce\AddOns\QuestHelper\libs\AceGUI-3.0\AceGUI-3.0.lua:125>
...ce\AddOns\QuestHelper\libs\AceGUI-3.0\AceGUI-3.0.lua:174: in function `Create'
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1113: in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1051>
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1078: in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1051>
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1538: in function `FeedGroup'
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1814: in function `Open'
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1842: in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1840>
(tail call): ?
[C]: ?
[string "safecall Dispatcher[2]"]:9: in function <[string "safecall Dispatcher[2]"]:5>
(tail call): ?
...ce\AddOns\QuestHelper\libs\AceGUI-3.0\AceGUI-3.0.lua:314: in function `Fire'
...GUI-3.0\widgets\AceGUIContainer-BlizOptionsGroup.lua:20: in function <...GUI-3.0\widgets\AceGUIContainer-BlizOptionsGroup.lua:19>
[C]: in function `Show'
Interface\FrameXML\InterfaceOptionsFrame.lua:28: in function `InterfaceOptionsList_DisplayPanel'
Interface\FrameXML\InterfaceOptionsFrame.lua:46: in function `InterfaceOptionsListButton_OnClick'
[string "*:OnClick"]:2: in function <[string "*:OnClick"]:1>

Locals: <none>

Followed by this:
Lua Error
Message: ...lper\libs\AceGUI-3.0\widgets\AceGUIWidget-Button.lua:66: CreateFrame(): Couldn't find inherited node "UIPanelButtonTemplate2"
Time: 01/18/13 21:31:04
Count: 4
Stack: (tail call): ?
[C]: ?
...lper\libs\AceGUI-3.0\widgets\AceGUIWidget-Button.lua:66: in function `?'
...ce\AddOns\QuestHelper\libs\AceGUI-3.0\AceGUI-3.0.lua:136: in function <...ce\AddOns\QuestHelper\libs\AceGUI-3.0\AceGUI-3.0.lua:125>
...ce\AddOns\QuestHelper\libs\AceGUI-3.0\AceGUI-3.0.lua:174: in function `Create'
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1113: in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1051>
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1078: in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1051>
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1538: in function `FeedGroup'
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1814: in function `Open'
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1842: in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1840>
(tail call): ?
[C]: ?
[string "safecall Dispatcher[2]"]:9: in function <[string "safecall Dispatcher[2]"]:5>
(tail call): ?
...ce\AddOns\QuestHelper\libs\AceGUI-3.0\AceGUI-3.0.lua:314: in function `Fire'
...GUI-3.0\widgets\AceGUIContainer-BlizOptionsGroup.lua:20: in function <...GUI-3.0\widgets\AceGUIContainer-BlizOptionsGroup.lua:19>
[C]: in function `Show'
Interface\FrameXML\UIParent.lua:1750: in function `SetUIPanel'
Interface\FrameXML\UIParent.lua:1555: in function `ShowUIPanel'
Interface\FrameXML\UIParent.lua:1481: in function <Interface\FrameXML\UIParent.lua:1477>
[C]: in function `SetAttribute'
Interface\FrameXML\UIParent.lua:2193: in function `ShowUIPanel'
[string "*:OnClick"]:2: in function <[string "*:OnClick"]:1>

Locals: <none>

Any thoughts there?

Update: I have switched to QuestMaster, as out of all the ones I have tried, it's the only one that works.

Xrystal 01-19-13 07:21 AM

That is a problem with the QuestHelper addon and/or the AceGUI library as it is using a template that I suspect no longer exists in Blizzard coding.

I suspect one or both of them have not been updated to 5.0 or above versions of wow yet.

Coasty 01-19-13 08:18 PM

The last version QuestHelper was updated for was update 5.0.5, so I would suspect that update 5.10 broke it.

Xrystal 01-19-13 08:48 PM

Hmm, maybe something else then .. I'm pretty sure UIPanelButtonTemplate2 was changed in 5.0.

Yeah looking at the blizz code they removed it in 5.0.4 so if your code isn't referencing the template directly it could be the library that needs updating.


All times are GMT -6. The time now is 11:04 PM.

vBulletin © 2018, Jelsoft Enterprises Ltd
© 2004 - 2017 MMOUI