Quantcast WoWInterface - View Single Post - Update issues
Thread: Update issues
View Single Post
02-16-15, 10:50 PM   #2
Dolby
PPAP
 
Dolby's Avatar
WoWInterface Admin
Join Date: Feb 2004
Posts: 2,229
Originally Posted by Phanx View Post
I updated Minion at work today (previous installed version was from Dec. 21, which I'd posted about here) and ran into some new issues.

The download link (which finally works when Google Analytics isn't loaded, yay!) seems to point at an old version. I clicked it 15 minutes ago, downloaded, installed, launched, and was immediately prompted to update again, though the in-app information listed the latest update as being 2-3 days old.
We released 2.1.2pl2 over the weekend. PL releases are emergency bug fixes and we do not always release a new 64/32 exes and dmgs for these. The download link will be in sync again once 2.1.3 is released. Luckily though these PL releases are well under 1mb in size.

Originally Posted by Phanx View Post
Despite this not being a fresh install, after the second update, I was prompted to select which drives to scan for games... and despite selecting only the C: drive which only contains one WoW install (and zero ESO installs) it proceeded to "detect" addons for 4 WoW installs. "Detecting WoW-4 AddOns" took about 10 minutes to complete.
Can you please attach your minion.xml. That should help me to detriment if something was wrong in the config or Minion is ignoring the config. Thanks

Originally Posted by Phanx View Post
Clicking the "maximize" button not only does not actually maximize the window (it leaves about 30px between itself and the edges of the screen) but also moved it to my other monitor (it was on the second monitor, and moved to the first one).
That is the way its worked since we launched maximize. With the radius corners and drop shadow there is a 12px inset.

The 2nd issue there is interesting. I see that now and will make a bug ticket for it.

Originally Posted by Phanx View Post
I don't see any misidentifications in the list this time, so that's good, but some addons are still missing. At a glance I think most, if not all, of the addons I previously reported as missing are still missing, but I don't have time to do a comprehensive survey right now.
Are they AddOns available from our Stand-Alone Addons category?

Originally Posted by Phanx View Post
However, Git repositories and SVN working copies are still not ignored, so that's bad, and I still can't try the "update all" or auto-update features. This really can't take very long to implement.
Its not a matter of difficulty, its a matter of time. Its in our backlog but re-writing the client and fixing the 100's of bugs you don't see take a lot of time. Every bug has been a deep rabbit hole and fixing one thing uncovers tons more. I wish we could go faster.

Originally Posted by Phanx View Post
System DPI is still ignored, and font rendering is still not great; note the blobby capital "B"s and "P"s in addon titles, and the general pixellated awfulness of the larger text:
I don't think JavaFX has this ability yet. I'll re-research this now that we are running JDK8 and JFX2.

Originally Posted by Phanx View Post
Low contrast is still a problem, but would be much less of a problem if the app scaled with the system DPI setting, since then the text would be larger.
I haven't had the time yet to work with the UI but I do want to work on this. I want to also provide a high contrast alternative style and possibly even find a way to open it for 3rd party styles. Although I think people will go crazy if they have to try and use the backwards jfx css.

Originally Posted by Phanx View Post
Version number boxes are still too narrow, and the tooltip delay is too long. When the window is "maximized" about 50% of the horizontal space is just blank -- there's plenty of room to show the whole version string when it's long!
I'll see if we can decrease the tooltip delay in javafx. I haven't gotten to resizing the version width. Hopefully now that we got the java8 re-write under our belt I can get back to more UI.

Originally Posted by Phanx View Post
Scrolling quickly is still jumpy, and still causes an annoying strobe effect since the mouseover highlight doesn't update at the same time as everything else. Version number boxes and "update" buttons are also affected -- when scrolling from "addons that need updates" (perhaps more properly entitled "lies" ) to "addons that are up to date" you can see the "update" button and the red/gray version boxes are still shown on the bottom few rows for a noticable fraction of a second before the update routine catches up. However, the addon icons and names update in realtime, so I'm not sure why the whole row isn't updated at the same time...
We had a story in sprint a couple times for this. We are having trouble capturing the scroll event under windows and calming it down. It scrolls like butter under OSX but horribly under windows. We are trying to figure out a solution to this.

Originally Posted by Phanx View Post
Typing in the search box is nicely responsive now... but deleting the contents of the search box by holding down the backspace key is very slow, like it's still using the old super-slow code path to filter the list each time the text contents changes while it's being deleted.
We should have a ( X ) icon show up to the right of the search input. I'll make a ticket for that. Thanks.

Originally Posted by Phanx View Post
Still getting weird cursors (usually <---> resize cursor) when mousing over addon rows most of the time.
Hrm, I can get the <---> to show up when hitting the edge of the window and if i drag it over the addon stats area in the list it stays but if I go further to the left it will turn back into a normal cursor. It stays a <---> a little too long though and should be fixed.


Thanks for your feedback and I do appreciate it.

Last edited by Dolby : 02-16-15 at 11:04 PM.
  Reply With Quote