Quantcast WoWInterface - View Single Post - oUF - Layout discussion
View Single Post
02-24-09, 12:14 PM   #797
Zyonin
Coffee powered Kaldorei
 
Zyonin's Avatar
AddOn Author - Click to view addons
Join Date: May 2006
Posts: 1,440
Hmm, so I redo my font stings as thus:

Health:
Code:
	self.Health.Text = self.Health:CreateFontString(nil, 'OVERLAY', 'GameFontHighlightSmallRight')
	self.Health.Text:SetFont('Interface\AddOns\oUF_Lyk\font.ttf', 14)
Power:
Code:
		local power = self.Power:CreateFontString(nil, 'OVERLAY', 'GameFontHighlightSmallLeft')
		power:SetFont('Interface\AddOns\oUF_Lyk\font.ttf', 14)
Target Name:
Code:
		local info = self.Health:CreateFontString(nil, 'OVERLAY', 'GameFontHighlightSmallLeft')
		info:SetFont('Interface\AddOns\oUF_Lyk\font.ttf', 14)
following the same format as the SetPoint line in each section.

All other modules (such as CastBar, etc) are currently disabled (their relavent sections are commented out) until I pin this down.
Worked through the idiot mistakes (like ")" in a weird spot due to a stupid typo on my part) and I get this barfed at me:

Code:
[2009/02/24 19:04:04-136-x1]: oUF-1.3.3\elements\tags.lua:269: <unnamed>:SetFormattedText(): Font not set
oUF-1.3.3\elements\tags.lua:269: in function `UpdateTag'
oUF-1.3.3\elements\tags.lua:142: in function `func'
oUF-1.3.3\ouf.lua:452: in function <Interface\AddOns\oUF\ouf.lua:447>
<in C code>: in function `Show'
Interface\FrameXML\SecureStateDriver.lua:72: in function <Interface\FrameXML\SecureStateDriver.lua:62>:
Interface\FrameXML\SecureStateDriver.lua:109: in function <Interface\FrameXML\SecureStateDriver.lua:79>:

  ---
Whatever I have done appears to make WoW blame oUF\elements\tags.lua even though I never touched it. For the time being I am going to revert back to the method that previously worked so I have a working layout for tonight, however I would like to get this pinned down.
__________________
LiveJournal | Twitter


Last edited by Zyonin : 02-24-09 at 12:24 PM.