Quantcast WoWInterface - View Single Post - NoTaint_UIDropDownMenu conflicts with MoveAnything
View Single Post
05-17-17, 12:14 AM   #27
arith
A Cyclonian
 
arith's Avatar
AddOn Author - Click to view addons
Join Date: May 2009
Posts: 44
Originally Posted by HonorGoG View Post
So I put in the new library and people complained about an error. Yep, I forgot to modify the .toc file to load the new xml file only. So I did that and continued testing. To make sure there are no conflicts with other addons, I'm only loading Swatter and Titan Panel. Now I'm seeing the following and I have no idea why this is happening as I don't see anything wrong with the xml file. But, it's late and work is pounding on me hard this week so my brain is pretty much fried by the time I get home. Any ideas?

Code:
Date: 2017-05-16 22:55:50
ID: 1
Error occured in: Global
Count: 1
Message: ..\AddOns\Titan\libs\NoTaint_UIDropDownMenu\UIDropDownMenu.xml line 1:
   unexpected symbol near '<'
Debug:
   
Locals:

AddOns:
  Swatter, v7.4.5714 (TasmanianThylacine)
  Titan, v5.11.4.70200
  BlizRuntimeLib_enUS v7.2.0.70200 <none>
  (ck=6b)

I look at your ToC file and you use embeds.xml to specify the path for libraries.
So then I look into the embeds.xml, my best guess it's you specify it by using Script:
Code:
<Script file="libs\NoTaint_UIDropDownMenu\UIDropDownMenu.xml"/>
You should use Include:
Code:
<Include file="libs\NoTaint_UIDropDownMenu\UIDropDownMenu.xml"/>
I did a test and once change it to Include, then everything works great.
  Reply With Quote