Quantcast
WoWInterface - View Single Post - How to use LineMixin?
View Single Post
05-02-18, 03:35 PM   #4
Xrystal
nUI Maintainer
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,464
d'oh ...

Just realised what they meant by mixing with a texture ..

xml...

<Texture parentKey="Background" mixin = "LineMixin">

And then I removed the CreateFromMixins line from the code element... it fixes the GetParent error but now getting problems figuring out what values will work.


Edit: Well no errors at all now - here is my xml file now

Code:
<UI>
    
        <Frame name="DraggingFrame" inherits = "DraggableFrameTemplate,DialogTemplate"   parent="UIParent" frameStrata="LOW">
		<Size x="200" y="300"/>
  		<Anchors>
			<Anchor point="CENTER" x = "0" y = "0" />
		</Anchors>
               
        <Frames>   
            <Frame name = "Canvas" parentKey = "Canvas">
                <Anchors>
                    <Anchor point="TOPLEFT"/>
                    <Anchor point="BOTTOMRIGHT"/>
                </Anchors>
                
                <Layers>
                    <Layer level="BACKGROUND">
                        <Texture name = "Paper" parentKey="Paper"> 
                            <Anchors>
                                <Anchor point="TOPLEFT"/>
                                <Anchor point="BOTTOMRIGHT"/>
                            </Anchors>
                            <Color r="0.0" g="0.0" b="0.0" a="0.5"/>
                        </Texture>
                    </Layer>
                    <Layer level="BACKGROUND" textureSubLevel="-2" alphaMode="ADD">
                        <Texture name = "Line"  parentKey="Line" mixin = "LineMixin"> 
                          <Size>
                            <AbsDimension x="1" y="1"/>
                          </Size>
                        <Anchors>
                            <Anchor point="CENTER" x = "0" y = "0" />
                        </Anchors>

                          <Color r="1.0" g="1.0" b="1.0" a="1.0"/>
                        </Texture>
                    </Layer>       
                </Layers>                
                <Scripts>
                    <OnLoad>
                        self.Line:SetStartPoint(0,0)
                        self.Line:SetEndPoint(100,100)
                        self.Line:SetThickness(32)
                        self.Line:Draw()
                    </OnLoad> 
               </Scripts>
            </Frame>
        </Frames>
        
        <Scripts>
            <OnLoad>
                self:RegisterForDrag("LeftButton")
            </OnLoad> 
       </Scripts>
    </Frame>

</UI>
I have tried everything that I thought would make it show up but no joy .. It might simply be due to my own understanding on how textures work
__________________

Last edited by Xrystal : 05-02-18 at 04:22 PM.
  Reply With Quote