Quantcast WoWInterface - View Single Post - PlaySound()
Thread: PlaySound()
View Single Post
07-17-17, 07:49 AM   #1
liquidbase
A Black Drake
 
liquidbase's Avatar
AddOn Author - Click to view addons
Join Date: Apr 2010
Posts: 82
PlaySound()

Hi there!

At the moment I work on the current version of DuffedUI to make it ready for 7.3.
I had a weird problem with PlaySound(). The line in my code ist correctly written and worked well on Live-Server but on PTR I get the following error-message:
Code:
1x DuffedUI\modules\loot\bags.lua:691: Usage: PlaySound(soundKitID, optional["SFX","Music","Ambience", "Dialog" or "Master"], [forceNoDuplicates, runFinishCallback])
[C]: in function `PlaySound'
DuffedUI\modules\loot\bags.lua:691: in function `CloseAllBags'
DuffedUI\modules\loot\bags.lua:711: in function `ToggleBags'
DuffedUI\modules\loot\bags.lua:785: in function `ToggleAllBags'
DuffedUI\modules\loot\bags.lua:794: in function `Enable'
DuffedUI\modules\loot\bags.lua:800: in function <DuffedUI\modules\loot\bags.lua:799>

Locals:
(*temporary) = "igBackPackClose"
The line in my bag-code looks like this one:
Lua Code:
  1. function Bags:CloseAllBags()
  2.     if MerchantFrame:IsVisible() or InboxFrame:IsVisible() then return end
  3.     CloseAllBags()
  4.     PlaySound("igBackPackClose")
  5. end

Soundfile is correct and the channel is not necessary because it is missing the client uses the master-channel. Anyone have the same issue or an idea how I can fix this?

greetz liquid
  Reply With Quote