Quantcast WoWInterface - View Single Post - Nameplates changing their alpha value mid-combat
View Single Post
11-29-17, 04:29 PM   #9
Kanegasi
A Frostmaul Preserver
 
Kanegasi's Avatar
AddOn Author - Click to view addons
Join Date: Apr 2007
Posts: 284
The raid frames actually don't mess up in combat anymore, at least from my experience. I uninstalled a similar addon at some point in the last year and my raid frames update just fine in combat. I have 199 addons installed according to Curse Client. CompactRaid...:Show() and SetTargetClampingInsets() are also huge problems with anything that could taint, sometimes frustratingly unrelated.

Try disabling RaidInterfaceAntidote and see what happens.

Edit: Ha, turns out that's the exact addon I used. I uninstalled it in February and posted this comment on the addon page.

This addon is no longer necessary. At some point in the last month or so, Blizzard did something to fix the raid frames.

I got tired of the "SetTargetClampingInsets" taint errors I kept getting with this (the very first replacement you do in the code is what causes that) and trying to fix them brings me back to the "CompactRaidFrame" errors. I got frustrated and just disabled the addon, but then I noticed that the raid frames were adding and removing players just fine while in combat during my world quests.

More testing is needed, but given the giant pile of addons I use and the large potential for something to taint, I'm pretty sure the raid frames are fixed. It also helps that I temporarily disabled all dropdown code in my Decliner addon, which I intend to fix and release eventually.

Last edited by Kanegasi : 11-29-17 at 04:33 PM. Reason: addon page comment
  Reply With Quote