Quantcast
Scroller not visible until the scroll offset change? - WoWInterface
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
07-21-21, 08:15 AM   #1
Zax
A Flamescale Wyrmkin
AddOn Author - Click to view addons
Join Date: Aug 2006
Posts: 117
Scroller not visible until the scroll offset change?

Hello,

I'm designing a scroller for a scroll frame and I have a problem with the scroller itself: it is not shown until I activate the scroll, by click on the arrow-down btn or by mouse-wheel.
The path to my .tga image is valid because the scroller is well visible once it has been "manually activated".

This is my code:
Lua Code:
  1. fSlider.texture = fSlider:CreateTexture("$parentThumbTexture", "BACKGROUND")
  2. fSlider.texture:SetTexture("pathToMyAddon.tga")
  3. fSlider.texture:SetSize(16, 24)
  4. fSlider.texture:SetTexCoord(0.25, 0.75, 0.125, 0.875)
  5. fSlider:SetThumbTexture(fSlider.texture)

It's a lua-converted code from the following XML found on the net:
Code:
<ThumbTexture name="$parentThumbTexture" inherits="UIPanelScrollBarButton" file="Interface\Buttons\UI-ScrollBar-Knob">
	<Size x="16" y="24"/>
	<TexCoords left="0.25" right="0.75" top="0.125" bottom="0.875"/>
</ThumbTexture>
Thank you.
__________________
Zax - Addons List, not all maintained.
  Reply With Quote
 

WoWInterface » Developer Discussions » Lua/XML Help » Scroller not visible until the scroll offset change?

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off