Quantcast [BETA] Could not open xml file(s). - WoWInterface
Thread Tools Display Modes
06-12-18, 05:53 PM   #1
Sweetsour
A Flamescale Wyrmkin
AddOn Author - Click to view addons
Join Date: Dec 2014
Posts: 126
[BETA] Could not open xml file(s).

I'm trying to get my addon loaded on the BfA beta, but I seem to be getting an error I haven't encountered before. I already made the changes to UnitBuff so that there's no other Lua errors. Below is an image of the error I'm getting.



Below is the code for the file in question
Lua Code:
  1. <Ui xmlns="http://www.blizzard.com/wow/ui/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.blizzard.com/wow/ui/
  2. ..\FrameXML\UI.xsd">
  3.     <Script file="bulletin.lua"/>
  4.     <Script file="elemental.lua"/>
  5.     <Script file="enhancement.lua"/>
  6.     <Script file="restoration.lua"/>
  7.     <Script file="init.lua"/>
  8. </Ui>

I noticed I'm also getting an "Error loading" error with LibDatabroker-1.1; not sure if that's part of the issue.
  Reply With Quote
06-12-18, 06:09 PM   #2
Fizzlemizz
I did that?
 
Fizzlemizz's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Dec 2011
Posts: 944
The error is saying it can't open the file, not that it has problems with the contents. Make sure the name/location of the xml file matches the entry on the .toc. In live the entry would just be ignored if the file didn't exist.

It also appears that you have a reference for the file in 4 different places which is odd so, maybe there are old associated addons that have this file listed in their .toc as well.
__________________
Fizzlemizz
Maintainer of Discord Unit Frames and Discord Art.
Author of FauxMazzle and Move Pad Plus.

Last edited by Fizzlemizz : 06-12-18 at 06:18 PM.
  Reply With Quote
06-12-18, 07:03 PM   #3
Sweetsour
A Flamescale Wyrmkin
AddOn Author - Click to view addons
Join Date: Dec 2014
Posts: 126
Yup, that did it. Had to re-organize my toc file and xml files. Thanks!
  Reply With Quote
06-19-18, 04:01 AM   #4
Cogwerkz
A Murloc Raider
 
Cogwerkz's Avatar
AddOn Author - Click to view addons
Join Date: Jul 2017
Posts: 9
What's new in this expansion (or at least in the BfA beta where I do my testing) is that addon loading will actually bug out on missing files, something it never did before.

Something else I have noticed which all really should be aware of, is that if an XML file tries to create a frame or other object with a global name that already exists, that too will cause a bug and prevent the addon from loading! So say you're using a library that embeds some XML template, and you load that library from different locations and they all try to create the same XML template with the same global name, then you have a loading error.

Sucks, but it's just how it is now.
  Reply With Quote

WoWInterface » Developer Discussions » Lua/XML Help » [BETA] Could not open xml file(s).

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off