Quantcast
Blizzards InterfaceOptions framework issues - WoWInterface
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
08-04-14, 05:17 PM   #1
Bringer
A Fallenroot Satyr
 
Bringer's Avatar
Join Date: Jul 2012
Posts: 26
Blizzards InterfaceOptions framework issues

While working on simple test code to verify the Boolean changes with version 6 World of Warcraft I stumbled upon a problem with InterfaceOptionsFrame_OpenToCategory(panel)

The code is just some quick and dirty that looks at how the running client version handles 0 | false | nil and 1 | true in logic structures and in Button check | select widgets.

What I found was if I included the above or even just InterfaceOptionsFrame:Show(); from within my addon code the default blizzard options got reset to default states. I believe the states are not being retrieve from the server, but I don't know since I wasn't even looking at the game options. This has been tested on 5.4.8 and current WoD beta.

I've looked at a number of other addons that are able to open the InterfaceOptionsFrame from addon without issue, but I can't figure out what they are doing that I missed.

I have searched here and via google and have scanned the current live version of FrameXML\GameMenuFrame (xml&lua) and InterfaceOptionsFrame (xlm&lua) without having the clue hammer hitting me.

The toc.. since that type can't be attached.

## Interface: 60000
## Version: 1
## X-SubVersion: AWod
## Title: Truth2

truth2.lua

Note: I commented out the offending calls (located at the bottom of file) so someone not prepared wouldn't find all there game options reset.
Attached Files
File Type: lua truth2.lua (8.7 KB, 84 views)
  Reply With Quote
 

WoWInterface » Developer Discussions » Lua/XML Help » Blizzards InterfaceOptions framework issues

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off