Quantcast
SetBackdropBorderColor Error - WoWInterface
Thread Tools Display Modes
01-02-21, 12:44 PM   #1
BloodDragon
A Fallenroot Satyr
AddOn Author - Click to view addons
Join Date: Mar 2017
Posts: 20
SetBackdropBorderColor Error

Hello @ all,
i have found a old Addon it works perfect but i have one Error.

Lua Code:
  1. 2x Farcaster\FarCaster-1.01.lua:54: attempt to call method 'SetBackdropBorderColor' (a nil value)
  2. [string "@Farcaster\FarCaster-1.01.lua"]:54: in function <Farcaster\FarCaster.lua:40>
  3.  
  4. Locals:
  5. self = <unnamed> {
  6.  0 = <userdata>
  7.  OnUpdate = <function> defined @Farcaster\FarCaster.lua:77
  8.  OnEvent = <function> defined @Farcaster\FarCaster.lua:40
  9. }
  10. event = "ADDON_LOADED"
  11. arg1 = "Farcaster"
  12. (*temporary) = nil
  13. (*temporary) = frmOptions {
  14.  0 = <userdata>
  15. }
  16. (*temporary) = 0.800000
  17. (*temporary) = 0.600000
  18. (*temporary) = 0.500000
  19. (*temporary) = 0.900000
  20. (*temporary) = "attempt to call method 'SetBackdropBorderColor' (a nil value)"
  21. iCurrentTalentTree = 3

Can anyone help me with this please?
Attached Files
File Type: lua FarCaster.lua (33.5 KB, 83 views)
  Reply With Quote
01-02-21, 01:25 PM   #2
Kanegasi
A Molten Giant
 
Kanegasi's Avatar
AddOn Author - Click to view addons
Join Date: Apr 2007
Posts: 575
Add the following line above the bordercolor line like so:

Lua Code:
  1. if not frmOptions.SetBackdrop then Mixin(frmOptions,BackdropTemplateMixin) end
  2. frmOptions:SetBackdropBorderColor(0.8, 0.6, 0.5, 0.9);
  Reply With Quote

WoWInterface » AddOns, Compilations, Macros » AddOn Help/Support » SetBackdropBorderColor Error

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off