Quantcast Giant Glowing Neon Buttons! - WoWInterface
Thread Tools Display Modes
11-27-12, 03:38 PM   #1
thespillmonkey
A Deviate Faerie Dragon
Join Date: Oct 2010
Posts: 11
Giant Glowing Neon Buttons!

Am i the only one whos ION is graphically messed up with 5.1?

PLEASE MAUL! DONT BE DEAD!
It has been months. We would love at least some word that you havent given up (or even if you have) on this addon.
  Reply With Quote
11-27-12, 03:41 PM   #2
Angrysteel
A Murloc Raider
Join Date: Jan 2008
Posts: 6
Hoping Phanx or one of the other well known mod authors will be able to look at this and give us some hints on how to fix it.

Im sure its an extremely easy fix, probably changing the backgrounds path or something of that nature.

But ya, these bars are unusable with the giant neon green surrounding every bar.


EDIT: I dont think its the bar backgrounds (if they even exist), but its on the buttons. The bag bars and the menu bars seem unaffected.
  Reply With Quote
11-27-12, 04:55 PM   #3
b1urry
A Defias Bandit
Join Date: Apr 2009
Posts: 3
I have posted the following in other areas where various authors will likely see, but I thought I'd drop it here too.

I believe I have found the issue. It seems to be related to some empty file pointers in the Ion__Core.xml. With 5.1 they must have changed the API to not allow empty files like this and this caused a green 'no image' placeholder to appear.

Apparently, the initial intent for the empty file strings was to provide a 'transparent' overlay. In one file instance I pointed it to a transparent button object and the green glow went away.

I'll do a bit more testing and make sure that what I'm doing doesn't break anything.
  Reply With Quote
11-27-12, 05:11 PM   #4
b1urry
A Defias Bandit
Join Date: Apr 2009
Posts: 3
yay to Maul!
  Reply With Quote
11-27-12, 10:33 PM   #5
Phanx
Cat.
 
Phanx's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2006
Posts: 5,617
Originally Posted by Angrysteel View Post
Hoping Phanx or one of the other well known mod authors will be able to look at this and give us some hints on how to fix it.
I've been using Bartender since MoP went live, and don't have the time or the interest to dig through such a huge project as Ion when I don't even use it anymore. I wish Maul had just updated Macaroon instead of abandoning a great addon and starting a new addon from scratch, but I find that Bartender is more than adequate for my needs nowadays. If Maul ever finds time to finish Ion and properly maintain/support it, I might give it a try, but I'm not holding my breath.

Originally Posted by b1urry View Post
With 5.1 they must have changed the API to not allow empty files like this and this caused a green 'no image' placeholder to appear.
This change was actually slated for the 5.0.4 release; I wasn't aware it hadn't gone live. The correct method now for clearing a texture is to set it to nil, not "".
__________________
Author/maintainer of Grid, PhanxChat, oUF_Phanx, and many more.
Troubleshoot an addonTurn any code into an addonMore addon resources
Need help with your code? Post all of your actual code! Attach or paste your files.
Please don’t PM me about addon bugs or code questions. Post a comment or forum thread instead!
  Reply With Quote

WoWInterface » Featured Projects » Ion Engines, Engage! » Giant Glowing Neon Buttons!

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off