Quantcast Routing errors - WoWInterface
 
Thread Tools Display Modes
11-26-10, 06:55 PM   #1
Thander
A Theradrim Guardian
Join Date: Apr 2009
Posts: 59
Routing errors

Solve: My Carbonite.lua was corrupted after switching to 4.0.3a version of Carbonite.


Using the latest beta (109), I get these errors when trying to use the Carbonite routing:

When setting a manual Goto:
Code:
Message: Interface\AddOns\Carbonite\Carbonite.lua:20669: attempt to index field 'BAT1' (a nil value)
Time: 11/26/10 16:53:08
Count: 2
Stack: Interface\AddOns\Carbonite\Carbonite.lua:20669: in function `CAT'
Interface\AddOns\Carbonite\Carbonite.lua:19842: in function `STAC'
Interface\AddOns\Carbonite\Carbonite.lua:20196: in function `Fun'
Interface\AddOns\Carbonite\Carbonite.lua:11229: in function <Interface\AddOns\Carbonite\Carbonite.lua:11211>

Locals: self = <table> {
 OLE = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:5223
 FiC4 = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:20342
 M_ORAW = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:9379
 ShU1 = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:13350
 SSM = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:18713
 M_ORW = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:12064
 ClC1 = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:13751
 M_OS3 = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:11191
 UpL1 = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:22635
 OUT = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:20277
 OnT = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:21315
 Set = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:14949
 Upd = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:7345
 OnW = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:19645
 M_OLQ = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:19950
 M_OSM = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:13748
 CAT = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:20665
 M_OA = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:17654
 M_OSQ = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:5785
 Ope = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:15497
 Up_ = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:6838
 ReW = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:9954
 WUF = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:790
 Add = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:12072
}
keT = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = "attempt to index field 'BAT1' (a nil value)"
When trying to use Route...->Current Gather Locations (after importing from Carbonite Nodes):
Code:
Message: Interface\AddOns\Carbonite\Carbonite.lua:20669: attempt to index field 'BAT1' (a nil value)
Time: 11/26/10 16:50:35
Count: 4
Stack: Interface\AddOns\Carbonite\Carbonite.lua:20669: in function `CAT'
Interface\AddOns\Carbonite\Carbonite.lua:22527: in function `RTT'
Interface\AddOns\Carbonite\Carbonite.lua:15868: in function `RoG'
Interface\AddOns\Carbonite\Carbonite.lua:24525: in function `Fun'
Interface\AddOns\Carbonite\Carbonite.lua:11229: in function <Interface\AddOns\Carbonite\Carbonite.lua:11211>

Locals: self = <table> {
 OLE = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:5223
 FiC4 = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:20342
 M_ORAW = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:9379
 ShU1 = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:13350
 SSM = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:18713
 M_ORW = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:12064
 ClC1 = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:13751
 M_OS3 = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:11191
 UpL1 = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:22635
 OUT = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:20277
 OnT = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:21315
 Set = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:14949
 Upd = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:7345
 OnW = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:19645
 M_OLQ = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:19950
 M_OSM = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:13748
 CAT = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:20665
 M_OA = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:17654
 M_OSQ = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:5785
 Ope = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:15497
 Up_ = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:6838
 ReW = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:9954
 WUF = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:790
 Add = <function> defined @Interface\AddOns\Carbonite\Carbonite.lua:12072
}
keT = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = "attempt to index field 'BAT1' (a nil value)"
After importing the nodes, I can turn on the gather locations on the map. It's just when I try routing that this happens.

Last edited by Thander : 11-29-10 at 12:27 PM.
 
 

WoWInterface » Featured Projects » Carbonite » Carbonite Archive » Routing errors

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off