Quantcast
RuneBar Update - WoWInterface
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
08-05-16, 04:40 PM   #1
neverg
A Frostmaul Preserver
 
neverg's Avatar
AddOn Author - Click to view addons
Join Date: Jul 2007
Posts: 264
RuneBar Update

Hi guys,

I'm been porting layout to Legion.

I was now testing the RuneBar and it is not working. Like not updating. It gets displayed correctly it just doesn't get depleted. I've set some prints on the runebar.lua in the update method and it seems it is not being called.

Anyone tested it or facing the same problem?

This is my code, pretty straightforward, I've compared it to other layouts, everything seems fine.


Lua Code:
  1. local CreateRuneBar = function(self)
  2.   local Runes = {}
  3.   for index = 1, 6 do
  4.     local Rune = CreateFrame('StatusBar', nil, self)
  5.     local numRunes, maxWidth, gap = 6, cfg.frames.main.width, 6
  6.     local width = ((maxWidth / numRunes) - (((numRunes-1) * gap) / numRunes))
  7.  
  8.     Rune:SetSize(width, cfg.frames.main.power.height)
  9.     Rune:SetStatusBarTexture(m.textures.status_texture)
  10.     Rune:SetStatusBarColor(unpack(oUF.colors.power["RUNES"]))
  11.     core:setBackdrop(Rune, 2, 2, 2, 2) -- Backdrop
  12.  
  13.     if(index == 1) then
  14.       Rune:SetPoint('TOPLEFT', self, 'BOTTOMLEFT', 0, -8)
  15.     else
  16.       Rune:SetPoint('LEFT', Runes[index - 1], 'RIGHT', gap, 0)
  17.     end
  18.     Runes[index] = Rune
  19.   end
  20.   self.Runes = Runes
  21. end



Again, they show up just fine, they just don't update.

Thanks.
__________________
My oUF Layout: oUF Lumen

Last edited by neverg : 08-05-16 at 04:46 PM.
  Reply With Quote
 

WoWInterface » Featured Projects » oUF (Otravi Unit Frames) » RuneBar Update

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off