Quantcast
Moving Blizzard Party Frames - WoWInterface
Thread Tools Display Modes
10-20-20, 06:35 PM   #1
kaytotes
A Deviate Faerie Dragon
AddOn Author - Click to view addons
Join Date: Nov 2014
Posts: 18
Moving Blizzard Party Frames

Basically prior to some time in 8.2 I believe something changed with regards to SetPoint usage. Since that point I've no longer been able to move the party frames in Retail however still can quite comfortably in Classic.

I create a drag frame that I used to parent the party frames too so that the position could be customised by end users. This now results in the following error.

Code:
6x ...eImprovedBlizzardUI\modules/frames/party.lua:59: Action[SetPoint] failed because[SetPoint would result in anchor family connection]: attempted from: PartyMemberFrame1:SetPoint.
[string "=[C]"]: in function `SetPoint'
A snippet for this can be found here where you can see i'm bailing out currently if it's retail however the code below did used to work and does on classic.

https://github.com/kaytotes/Improved...ty.lua#L45-L65

Does anyone have any advice for how I can bring back this functionality for Shadowlands onwards?

Last edited by kaytotes : 10-20-20 at 09:05 PM.
  Reply With Quote

WoWInterface » Developer Discussions » Lua/XML Help » Moving Blizzard Party Frames

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off