Quantcast Issue showing texture on string - WoWInterface
Thread Tools Display Modes
06-29-18, 09:27 AM   #1
maqjav
An Aku'mai Servant
Join Date: Feb 2012
Posts: 38
Issue showing texture on string

Hello.

I have a list of items and I'm trying to show their icons on a tooltip using LibQ-Tip.

For every item I get its information calling GetItemInfo(itemID), and with the texture received I add a new cell to my tooltip:

Code:
tooltip:SetCell(line, i, "|T"..iconFileDataID..":24|t", nil, "CENTER", 1, nil, nil, nil, nil, 24)
All the icons will be rendered except the last one (or 2). I guess it's a timing issue, perhaps the string is rendered before the icon is fetched or something like that?


SOLUTION:
Found the problem, my index was overriding the last position with an empty space, that's why the icon was being lost.
I cannot delete this post, so please, someone with privileges do it

Thanks!

Last edited by maqjav : 06-29-18 at 11:25 AM.
  Reply With Quote
06-29-18, 09:52 PM   #2
jeffy162
A Pyroguard Emberseer
 
jeffy162's Avatar
AddOn Author - Click to view addons
Join Date: May 2009
Posts: 2,285
This post probably won't get deleted. It's informative, and that's why. Someone else might have the same (or similar) problem, and come here (to this site) looking for a solution.
__________________
Ahhhh, the vagueries of the aging mind. Wait.... What was I saying?


Carbonite <----- GitHub main module (Maps ONLY) download link. The other modules are also available on GitHub.
  Reply With Quote
06-30-18, 03:38 PM   #3
Seerah
Fishing Trainer
 
Seerah's Avatar
WoWInterface Super Mod
Featured
Join Date: Oct 2006
Posts: 10,556
But I will move it to the right forum.
__________________
"You'd be surprised how many people violate this simple principle every day of their lives and try to fit square pegs into round holes, ignoring the clear reality that Things Are As They Are." -Benjamin Hoff, The Tao of Pooh

  Reply With Quote

WoWInterface » Developer Discussions » Lua/XML Help » Issue showing texture on string

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off