Quantcast Memory issues and GetItem* functions - WoWInterface
 
Thread Tools Display Modes
07-20-16, 12:55 PM   #1
lightspark
A Rage Talon Dragon Guard
 
lightspark's Avatar
AddOn Author - Click to view addons
Join Date: Sep 2012
Posts: 328
Memory issues and GetItem* functions

Hi!

There's an issue with GetItemInfo and other item functions, that use item IDs. Passing big integers to these functions causes memory issues.

For example, this call
Lua Code:
  1. GetItemInfo(1234567890)
increased memory usage up to 5-6GB.



Further GetItemInfo calls, even GetItemInfo(1), hogged even more memory, and eventually crashed the client.

When client crashed I got a window saying
Not enough memory. Please refer to https://battle.net/support/article/6926 to find out how to reduce your memory usage
__________________

Last edited by lightspark : 07-20-16 at 01:05 PM.
 
07-20-16, 06:17 PM   #2
Lombra
A Molten Giant
 
Lombra's Avatar
AddOn Author - Click to view addons
Join Date: Nov 2006
Posts: 554
I had this earlier on the live 7.0 patch. I did not have the time to pinpoint it at the time, but indeed I was messing about with GetItemInfo.
__________________
Grab your sword and fight the Horde!
 
 

WoWInterface » Site Forums » Archived Beta Forums » Legion Beta archived threads » Memory issues and GetItem* functions

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off