Quantcast
Updating OUF causes issues without LUA errors - WoWInterface
Thread Tools Display Modes
11-15-17, 04:45 AM   #1
Galaxy119
A Flamescale Wyrmkin
 
Galaxy119's Avatar
AddOn Author - Click to view addons
Join Date: Aug 2014
Posts: 111
Updating OUF causes issues without LUA errors

For the record: I'm currently using oUF v. 1.6.8 in my UI addon. It still works, but there, of course, are reasons to use an updated version - Mainly I wouldn't need to maintain my own classpower modules for every class seperately in the UI, among other things (the impending fear that any patch could potentially break 1.6.8 completely and leave me crying on my keyboard).

However - I'm thrown for a loop whenever I try to upgrade the oUF I use in my UI..

First of all, I have to remove
lua Code:
  1. if(_VERSION:find('project%-version')) then
  2.     _VERSION = 'devel'
  3. end
from oUF/ouf.lua otherwise my addon errors on that segment and bad things happen.
upon removing the code, I get no errors, but my non-player frames are broken:



I've tracked down the green bars issue to simply being my current implementation of healprediction, which can be easily resolved, however all of the other issues remain. The target's frame texture isn't loaded, all units have all raid icons shown above them, etc.
With no errors being displayed, I'm not exactly sure where to begin with fixing it..

To be frank - I'm not a veteran coder, I took charge of maintaining Roth UI from the original developer zork as he has no interest in it.
While i have been able to implement some minor features on my own like the nameplates, more orb custimizations and better artwork, this , I fear, is beyond me.

Usually when things break, I rely on lua errors to at least point me in the right direction.


If anyone is willing to help me figure this out, that'd be lovely.
__________________
My Addons | "If someone says something is impossible, they either lack imagination, or lack determination."
  Reply With Quote
11-15-17, 06:06 AM   #2
p3lim
A Pyroguard Emberseer
 
p3lim's Avatar
AddOn Author - Click to view addons
Join Date: Feb 2007
Posts: 1,703
Originally Posted by Galaxy119 View Post
First of all, I have to remove
lua Code:
  1. if(_VERSION:find('project%-version')) then
  2.     _VERSION = 'devel'
  3. end
from oUF/ouf.lua otherwise my addon errors on that segment and bad things happen.
What errors?

Originally Posted by Galaxy119 View Post
upon removing the code, I get no errors, but my non-player frames are broken:

... image ...

I've tracked down the green bars issue to simply being my current implementation of healprediction, which can be easily resolved, however all of the other issues remain. The target's frame texture isn't loaded, all units have all raid icons shown above them, etc.
With no errors being displayed, I'm not exactly sure where to begin with fixing it..
Most elements were renamed in oUF 7.0, you'll have to update your layout to reflect that.
If oUF doesn't see an element it doesn't know what to show/hide.

Your first step should be to follow the upgrade guide: http://www.wowinterface.com/forums/s...ad.php?t=55422
  Reply With Quote
11-15-17, 06:32 AM   #3
Galaxy119
A Flamescale Wyrmkin
 
Galaxy119's Avatar
AddOn Author - Click to view addons
Join Date: Aug 2014
Posts: 111
1. it simply says _VERSION is a nil value and breaks the rest of the addon completely.

2. According to that guide, nothing related to names of the target frame itself were changed. The raid icons I can fix easily enough, and as stated the healprediction is causing the green bars to be wonky, but resolving both those issues, I see no other element changes detailed there that would prevent the target frame from producing it's artwork while still appearing in the correct position and correct size.

One of the main reasons I've waited to long to do this update is I feel a near entire re-write of my UI would be necessary to accomplish it, and I've not the time nor experience to carry out such a task :/
__________________
My Addons | "If someone says something is impossible, they either lack imagination, or lack determination."
  Reply With Quote
11-15-17, 02:24 PM   #4
p3lim
A Pyroguard Emberseer
 
p3lim's Avatar
AddOn Author - Click to view addons
Join Date: Feb 2007
Posts: 1,703
Originally Posted by Galaxy119 View Post
1. it simply says _VERSION is a nil value and breaks the rest of the addon completely.
I see, I know where the error is, thanks for letting me know.

Originally Posted by Galaxy119 View Post
2. According to that guide, nothing related to names of the target frame itself were changed.
You mean the global name of the frame?
If so, that is either provided by you (in oUF:Spawn(unit, frameName)), or it's generated for you, using the style name (e.g. if the style is "Foo" the name of the target frame would be "oUF_FooTarget").
  Reply With Quote
11-15-17, 02:37 PM   #5
p3lim
A Pyroguard Emberseer
 
p3lim's Avatar
AddOn Author - Click to view addons
Join Date: Feb 2007
Posts: 1,703
Regarding 1.:
https://github.com/oUF-wow/oUF/pull/401

Should be merged soon, and a version will be pushed.
  Reply With Quote
11-15-17, 10:50 PM   #6
Galaxy119
A Flamescale Wyrmkin
 
Galaxy119's Avatar
AddOn Author - Click to view addons
Join Date: Aug 2014
Posts: 111
1. Yay I helped fix something!

2. Exactly, the frame name is set by me, and the artwork is tied to the name i set, along with all the other values for location, size, etc. There's no reason the text should appear in the proper places on/around the bars, but the textures don't.

What's even weirder is some frames (the target's target for example doesn't appear to have this bug, I'll try and dig into the lua more to figure it out I guess, but I'm at a loss :S
__________________
My Addons | "If someone says something is impossible, they either lack imagination, or lack determination."
  Reply With Quote
11-16-17, 03:35 PM   #7
p3lim
A Pyroguard Emberseer
 
p3lim's Avatar
AddOn Author - Click to view addons
Join Date: Feb 2007
Posts: 1,703
Add a print next to wherever you've coded to add the texture to check if the frame exists, I suspect you're trying to add it before it's even created.
  Reply With Quote

WoWInterface » Featured Projects » oUF (Otravi Unit Frames) » Updating OUF causes issues without LUA errors

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off