Quantcast
Reputation.lua file is not being loaded - WoWInterface
Thread Tools Display Modes
09-22-21, 01:44 AM   #1
myrroddin
A Pyroguard Emberseer
 
myrroddin's Avatar
AddOn Author - Click to view addons
Join Date: Oct 2008
Posts: 1,176
Reputation.lua file is not being loaded

I was updating ElvUI_PCDB and I've run into a strange issue. Core.lua is throwing a nil error for a function in Reputation.lua, which means the function isn't being called, so I added an error debug near the top. The error didn't fire.

Which means the file itself isn't loading. I've created it again, in case of corruption, and that wasn't the issue. I have checked the ToC and the file is listed. I honestly cannot figure out why the game isn't loading the file.

Of course, to really test, someone needs ElvUI, and they people on their Discord have greatly helped, but this is beyond them. It's a game issue.

Why is this Lua file not loading? I have tried both with C_Timer.After and without, like the commented out other lines in Core.lua. EX:
Code:
--EPDBC:HookXPBar()
C_Timer.After(0.5, EPDBC.HookRepBar)
C_Timer.After(0.5, EPDBC.HookHonorBar)
[email protected]@
--EPDBC:HookAzeriteBar()
[email protected]@
Honor.lua and its function both work. I honestly do not understand why this file isn't loading.
Lua Code:
  1. 3x ElvUI_PDBC\Core.lua:110: Usage: C_Timer.After(seconds, func)
  2. [string "=[C]"]: in function `After'
  3. [string "@ElvUI_PDBC\Core.lua"]:110: in function `StartUp'
  4. [string "@ElvUI_PDBC\Core.lua"]:39: in function <ElvUI_PDBC\Core.lua:36>
  5. [string "=[C]"]: ?
  6. [string "@ElvUI\Core\Core.lua"]:1753: in function `CallLoadFunc'
  7. [string "@ElvUI\Core\Core.lua"]:1768: in function `CallLoadedModule'
  8. [string "@ElvUI\Core\Core.lua"]:1794: in function `InitializeModules'
  9. [string "@ElvUI\Core\Core.lua"]:1898: in function <ElvUI\Core\Core.lua:1866>
  10. [string "=[C]"]: in function `Initialize'
  11. [string "@ElvUI\init.lua"]:163: in function <ElvUI\init.lua:162>
  12. [string "=[C]"]: ?
  13. [string "@Ace3\AceAddon-3.0\AceAddon-3.0-13.lua"]:70: in function <Ace3\AceAddon-3.0\AceAddon-3.0.lua:65>
  14. [string "@Ace3\AceAddon-3.0\AceAddon-3.0-13.lua"]:527: in function `EnableAddon'
  15. [string "@Ace3\AceAddon-3.0\AceAddon-3.0-13.lua"]:630: in function <Ace3\AceAddon-3.0\AceAddon-3.0.lua:615>
Attached Files
File Type: zip ElvUI_PDBC.zip (147.2 KB, 19 views)
  Reply With Quote
09-22-21, 03:36 AM   #2
myrroddin
A Pyroguard Emberseer
 
myrroddin's Avatar
AddOn Author - Click to view addons
Join Date: Oct 2008
Posts: 1,176
I tested with the function HookXPBar, and it has the same error. Why are these files not loading?
  Reply With Quote
09-22-21, 09:49 AM   #3
Fizzlemizz
I did that?
 
Fizzlemizz's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Dec 2011
Posts: 1,429
Your .toc, as presented, has the Reputation.lua file effectively commented out with the # so it doesn't load making EPDBC.HookRepBar nil.
__________________
Fizzlemizz
Maintainer of Discord Unit Frames and Discord Art.
Author of FauxMazzle, FauxMazzleHUD and Move Pad Plus.

Last edited by Fizzlemizz : 09-22-21 at 10:22 AM.
  Reply With Quote
09-22-21, 04:23 PM   #4
myrroddin
A Pyroguard Emberseer
 
myrroddin's Avatar
AddOn Author - Click to view addons
Join Date: Oct 2008
Posts: 1,176
Originally Posted by Fizzlemizz View Post
Your .toc, as presented, has the Reputation.lua file effectively commented out with the # so it doesn't load making EPDBC.HookRepBar nil.
OMG, thank you. I was looking at my dev ToC file, which is not commented out. I feel sooooo dumb. I never looked at the test folder in my AddOns directory. Grrrr I must be taking the Stupid Pills again!
  Reply With Quote

WoWInterface » Developer Discussions » Lua/XML Help » Reputation.lua file is not being loaded

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off