Quantcast
QueryAuctionItems causes error in Blizzard_AuctionUI.lua - WoWInterface
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
07-19-16, 08:18 PM   #1
ceylina
A Wyrmkin Dreamwalker
Join Date: Oct 2014
Posts: 50
QueryAuctionItems causes error in Blizzard_AuctionUI.lua

QueryAuctionItems() full scan (equivalent of getAll) returns error

Running the following if you can run a full scan (as checked by CanSendAuctionQuery()) wil lthrow an error

To reporduce:

Have no addons loaded
Open Auciton house

In chat run

/run QueryAuctionItems( "", nil, nil, 0, 0, 0, true, false, nil )

wait...

Will return the following error example (this was taken from the live servers, results may be different)

Code:
aceBlizzard_AuctionUI\Blizzard_AuctionUI.lua:733: attempt to index local 'color' (a nil value)
...aceBlizzard_AuctionUI\Blizzard_AuctionUI.lua:733: in function `AuctionFrameBrowse_Update'
...aceBlizzard_AuctionUI\Blizzard_AuctionUI.lua:260: in function <...aceBlizzard_AuctionUI\Blizzard_AuctionUI.lua:258>

Locals:
numBatchAuctions = 59607
totalAuctions = 59607
button = BrowseButton1 {
 0 = <userdata>
}
buttonName = "BrowseButton1"
buttonHighlight = BrowseButton1Highlight {
 0 = <userdata>
}
iconTexture = nil
itemName = BrowseButton1Name {
 0 = <userdata>
}
color = nil
itemCount = nil
moneyFrame = nil
yourBidText = nil
buyoutFrame = nil
buyoutMoney = nil
offset = 0
index = 1
isLastSlotEmpty = false
name = ""
texture = nil
count = 1
quality = -1
canUse = false
level = -1805820848
levelColHeader = nil
minBid = 14048
minIncrement = 0
buyoutPrice = 17028
duration = 4
bidAmount = 0
highBidder = false
bidderFullName = nil
owner = nil
ownerFullName = nil
saleStatus = 0
itemId = 3575
hasAllInfo = false
displayedPrice = nil
requiredBid = nil
(for index) = 1
(for limit) = 8
(for step) = 1
i = 1
(*temporary) = <function> defined =[C]:-1
(*temporary) = BrowseButton1Name {
 0 = <userdata>
}
(*temporary) = ""
(*temporary) = <userdata>
(*temporary) = false
(*temporary) = -1805820848
(*temporary) = nil
(*temporary) = 14048
(*temporary) = 0
(*temporary) = 17028
(*temporary) = 0
(*temporary) = false
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = 0
(*temporary) = 3575
(*temporary) = false
(*temporary) = "attempt to index local 'color' (a nil value)"
This no longer occurs in Beta so something has changed between live and Beta

Last edited by ceylina : 07-19-16 at 11:48 PM.
 
 

WoWInterface » Site Forums » Archived Beta Forums » Legion Beta archived threads » QueryAuctionItems causes error in Blizzard_AuctionUI.lua

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off