Quantcast
Error with addons - WoWInterface
 
Thread Tools Display Modes
12-10-16, 06:40 AM   #1
Trommy
A Fallenroot Satyr
 
Trommy's Avatar
Join Date: Jan 2013
Posts: 23
Error with addons

Whats wrong in this errors?

Code:
1x [ADDON_ACTION_BLOCKED] Аддон 'whoaUnitFrames' пытался вызвать защищенную функцию 'CompactRaidFrame4:Show()'.
!BugGrabber\BugGrabber.lua:573: in function <!BugGrabber\BugGrabber.lua:573>
[C]: in function `Show'
FrameXML\CompactUnitFrame.lua:339: in function `CompactUnitFrame_UpdateVisible'
FrameXML\CompactUnitFrame.lua:280: in function `CompactUnitFrame_UpdateAll'
FrameXML\CompactUnitFrame.lua:115: in function <FrameXML\CompactUnitFrame.lua:51>

Locals:
And this:
Code:
1x [ADDON_ACTION_BLOCKED] Аддон 'whoaUnitFrames' пытался вызвать защищенную функцию 'PartyMemberFrame3:Show()'.
!BugGrabber\BugGrabber.lua:573: in function <!BugGrabber\BugGrabber.lua:573>
[C]: in function `Show'
FrameXML\PartyMemberFrame.lua:141: in function `PartyMemberFrame_UpdateMember'
FrameXML\PartyMemberFrame.lua:365: in function `PartyMemberFrame_OnEvent'
[string "*:OnEvent"]:1: in function `OnEvent'
FrameXML\UnitFrame.lua:917: in function <FrameXML\UnitFrame.lua:915>

Locals:
Code:
1x [ADDON_ACTION_BLOCKED] Аддон 'WorldQuestTracker' пытался вызвать защищенную функцию '<unnamed>:Hide()'.
!BugGrabber\BugGrabber.lua:573: in function <!BugGrabber\BugGrabber.lua:573>
[C]: in function `Hide'
FrameXML\WorldMapActionButton.lua:58: in function `Clear'
FrameXML\WorldMapActionButton.lua:67: in function `Refresh'
FrameXML\WorldMapActionButton.lua:19: in function `SetMapAreaID'
FrameXML\WorldMapFrame.lua:418: in function <FrameXML\WorldMapFrame.lua:381>
[C]: in function `Hide'
FrameXML\UIParent.lua:2358: in function `SetUIPanel'
FrameXML\UIParent.lua:2385: in function `MoveUIPanel'
FrameXML\UIParent.lua:2416: in function `HideUIPanel'
FrameXML\UIParent.lua:2090: in function <FrameXML\UIParent.lua:2082>
[C]: in function `SetAttribute'
FrameXML\UIParent.lua:2884: in function `HideUIPanel'
FrameXML\UIParent.lua:2850: in function `ToggleFrame'
FrameXML\WorldMapFrame.lua:242: in function <FrameXML\WorldMapFrame.lua:233>
[C]: in function `ToggleWorldMap'
[string "TOGGLEWORLDMAP"]:1: in function <[string "TOGGLEWORLDMAP"]:1>

Locals:
And how fix it? All addons is up to date. No addons for raid or party, only default

Last edited by Trommy : 12-10-16 at 06:50 AM.
  Reply With Quote
12-10-16, 12:42 PM   #2
Seerah
Fishing Trainer
 
Seerah's Avatar
WoWInterface Super Mod
Featured
Join Date: Oct 2006
Posts: 10,734
Since the actual error is in Russian, I'm not sure.
__________________
"You'd be surprised how many people violate this simple principle every day of their lives and try to fit square pegs into round holes, ignoring the clear reality that Things Are As They Are." -Benjamin Hoff, The Tao of Pooh

  Reply With Quote
12-10-16, 02:21 PM   #3
jeffy162
A Pyroguard Emberseer
 
jeffy162's Avatar
AddOn Author - Click to view addons
Join Date: May 2009
Posts: 2,351
Your errors are, unfortunately for me, all in Russian. I don't speak Russian, but, it looks like the errors are being caused by two addons. Whoa Unit Frames and World Quest Tracker. If they are not enabled, I would be asking "Why are these addons causing errors if they are NOT enabled???".

By-the-way, those addons are up to date.

I looked over your post again and I noticed errors from BugGrabber also. WTH? BugGrabber never errors!
Besides, it's up to date also.
__________________
Ahhhh, the vagueries of the aging mind. Wait.... What was I saying?


Carbonite <----- GitHub main module (Maps ONLY) download link. The other modules are also available on GitHub.
Carbonite-CLASSIC<----- GitHub link to Carbonite Classic. Thanks to ircdirk for this!

Last edited by jeffy162 : 12-10-16 at 02:38 PM. Reason: More useless twaddle (blah-blah-blah).
  Reply With Quote
12-10-16, 07:18 PM   #4
SDPhantom
A Pyroguard Emberseer
 
SDPhantom's Avatar
AddOn Author - Click to view addons
Join Date: Jul 2006
Posts: 1,924
Honestly, the presence of ADDON_ACTION_BLOCKED is saying it's responding to a taint event rather than an actual Lua error. Translation is redundant, but here's what I got.
The addon 'whoaUnitFrames' tried to call a protected function 'CompactRaidFrame4: Show ()'.
-Google Translate
It's the standard taint error. Beyond that, there's really nothing else the error describes. The addon did something that resulted in the taint of the execution path or Blizzard's code screwing something up (as it often does). My first suggestion would be to do a UI reload when this happens and hope it doesn't do it again very often. If it does, you might want to consider uninstalling the addon.



Originally Posted by jeffy162 View Post
I looked over your post again and I noticed errors from BugGrabber also. WTH? BugGrabber never errors!
BugGrabber isn't necessarily erroring. It needs to change the offset to debugstack() as it's now including its own internal functions in the list.
__________________
ESOUI AddOns | WoWInterface AddOns
"All I want is a pretty girl, a decent meal, and the right to shoot lightning at fools."
-Anders (Dragon Age: Origins - Awakening)

Last edited by SDPhantom : 12-10-16 at 07:32 PM.
  Reply With Quote
12-12-16, 09:58 AM   #5
Trommy
A Fallenroot Satyr
 
Trommy's Avatar
Join Date: Jan 2013
Posts: 23
Yes, both addons is On. I fear not errors. Just freezes. Freezes without fps down. Freezes start only when raid start battle and just into the LFR (dont go normal/etc cuz unpalyable freezes). On BG all is good, no errors. And on the local quests smtimes start freezes, but rarely like into LFR. And all my addons is up to date.
  Reply With Quote

WoWInterface » AddOns, Compilations, Macros » AddOn Help/Support » Error with addons

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off