Quantcast Moving moving buffs from BuffFrame tainting UI - WoWInterface
Thread Tools Display Modes
09-12-18, 06:13 PM   #1
Capadillo
A Murloc Raider
Join Date: Jan 2014
Posts: 7
Moving moving buffs from BuffFrame tainting UI

Hey guys, I'm working on my personal UI and keep running into issues. One such issue is the following...

Code:
1x [ADDON_ACTION_BLOCKED] AddOn 'CaUI' tried to call the protected function 'MainMenuBar:SetPoint()'.
!BugGrabber\BugGrabber.lua:519: in function <!BugGrabber\BugGrabber.lua:519>
[C]: in function `SetPoint'
FrameXML\UIParent.lua:2946: in function `UIParentManageFramePositions'
FrameXML\UIParent.lua:2329: in function <FrameXML\UIParent.lua:2316>
[C]: in function `SetAttribute'
FrameXML\UIParent.lua:3118: in function `UIParent_ManageFramePositions'
FrameXML\BuffFrame.lua:331: in function <FrameXML\BuffFrame.lua:283>
[C]: in function `BuffFrame_UpdateAllBuffAnchors'
FrameXML\BuffFrame.lua:104: in function `BuffFrame_Update'
FrameXML\BuffFrame.lua:49: in function <FrameXML\BuffFrame.lua:45>
I'm not modifying the BuffFrame directly, I am however moving all buffs and debuffs to new frames. Is there a way to move them without causing issues or do I need to recreate the buffs?

EDIT:

Pastebin of the file containing the changes to BuffFrame_Update...
https://pastebin.com/qExcvBUH

Last edited by Capadillo : 09-12-18 at 07:26 PM. Reason: added pastebin link
  Reply With Quote
09-13-18, 01:29 AM   #2
zork
A Pyroguard Emberseer
 
zork's Avatar
AddOn Author - Click to view addons
Join Date: Jul 2008
Posts: 1,729
Here is what I am doing with rBuffFrame
https://github.com/zorker/rothui/blo.../core.lua#L107
https://github.com/zorker/rothui/blo...layout.lua#L17
__________________
| Simple is beautiful.
| WoWI AddOns | GitHub | Zork (WoW) | TDMOG

"I wonder what the non-pathetic people are doing tonight?" - Rajesh Koothrappali (The Big Bang Theory)
  Reply With Quote
09-13-18, 05:02 PM   #3
Capadillo
A Murloc Raider
Join Date: Jan 2014
Posts: 7
What I wrote is heavily inspired by your rBuffFrame lib. Though I simplified it a lot compared to yours. The only main difference I can see is that you're re-parenting the BuffFrame to a hidden frame. Not sure if that'll solve the issue, but I'll give it a shot.

EDIT: Whoops! I somehow missed that was commented out. My mistake.

Last edited by Capadillo : 09-13-18 at 05:18 PM. Reason: didn't read properly
  Reply With Quote

WoWInterface » Developer Discussions » Lua/XML Help » Moving moving buffs from BuffFrame tainting UI

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off