Quantcast
Re-coloring Textures - WoWInterface
Thread Tools Display Modes
11-17-11, 02:41 PM   #1
Miiru
A Flamescale Wyrmkin
 
Miiru's Avatar
AddOn Author - Click to view addons
Join Date: Dec 2008
Posts: 138
Re-coloring Textures

Hey there.

I'm trying to make my Texture pack Patch 4.3 ready, but i'm struggeling with the purple tinting they implemented to the Reforging, transmogrify and Void Storage Frames.

I tried to recolor them using SetVertexColor, but it doesnt seem to work.

Code:
<Frame name="TransmogrifyFrame" toplevel="true" parent="UIParent" hidden="true" enableMouse="true">
<Size x="338" y="424"/>
<Frames>
<DressUpModel name="TransmogrifyModelFrame" inherits="ModelWithControlsTemplate">
<Layers>
<Layer level="BACKGROUND" textureSubLevel="1">
<Texture name="$parentMarbleBg" file="Interface\FrameGeneral\UI-Background-Marble" horizTile="true" vertTile="true" setAllPoints="true"/>
</Layer>
<Layer level="BACKGROUND" textureSubLevel="2">
<Texture setAllPoints="true">
<Color r="0.302" g="0.102" b="0.204" a="0.5"/>
</Texture>
</Layer>
(whole xml: click)

I read a bit about $parent and so i concluded the tetures name should be "TransmogrifyFrameMarbleBg". Tried to change the color with setverteycolor, but it didnt change anything. I also tried to copy the whole xml file and then change the color code, which did not work either. I guess i'm doing it totally wrong? :X
  Reply With Quote
11-17-11, 04:32 PM   #2
Ailae
A Rage Talon Dragon Guard
 
Ailae's Avatar
AddOn Author - Click to view addons
Join Date: Dec 2007
Posts: 318
Wild guess, but wouldn't the parent rather be TransmogrifyModelFrame?

Thus, the texture would be TransmogrifyModelFrameMarbleBg.
__________________
Oh, the simulated horror!
  Reply With Quote
11-18-11, 04:14 AM   #3
Miiru
A Flamescale Wyrmkin
 
Miiru's Avatar
AddOn Author - Click to view addons
Join Date: Dec 2008
Posts: 138
Originally Posted by Ailae View Post
Wild guess, but wouldn't the parent rather be TransmogrifyModelFrame?

Thus, the texture would be TransmogrifyModelFrameMarbleBg.
If i remember correctly, i tried that one already but im not sure. Waiting for PTR to come online to test...

Last edited by Miiru : 11-18-11 at 04:40 AM.
  Reply With Quote
11-19-11, 04:08 AM   #4
Miiru
A Flamescale Wyrmkin
 
Miiru's Avatar
AddOn Author - Click to view addons
Join Date: Dec 2008
Posts: 138
Ok TransmogrifyModelFrameMarbleBg worked, but now i have another problem.

Is there a way to 'delete' the color information set by the .xml file? Because if i try to color it by setvertexcolor it just adds the color over the already colored texture... i already to calculate the necessary color code to get the color i want but i wasnt really successfull
  Reply With Quote
11-19-11, 03:58 PM   #5
Miiru
A Flamescale Wyrmkin
 
Miiru's Avatar
AddOn Author - Click to view addons
Join Date: Dec 2008
Posts: 138
Apparentely i need to hook the setvertexcolor call. I searched a bit on google and didnt really find anything that helped me :/

edit: solved the problems.

Last edited by Miiru : 11-21-11 at 08:27 AM.
  Reply With Quote

WoWInterface » Developer Discussions » Lua/XML Help » Re-coloring Textures

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off