Quantcast
ComboPointPlayerFrame SetPoint - WoWInterface
Thread Tools Display Modes
01-02-21, 02:36 PM   #1
3njoi
A Murloc Raider
Join Date: Dec 2020
Posts: 5
ComboPointPlayerFrame SetPoint

I'm trying to anchor default combo points to the personal resource bar. Why? Cause they have nicer animations than the default prb combo points :P. It seems to work but I keep getting this error.
Action[SetPoint] failed because[SetPoint would result in anchor family connection]: attempted from: ComboPointPlayerFrame:SetPoint.
This is the code I'm using.

Lua Code:
  1. UIPARENT_MANAGED_FRAME_POSITIONS.ComboPointPlayerFrame = nil
  2. ComboPointPlayerFrame.Background:Hide()
  3. ComboPointPlayerFrame:HookScript("OnUpdate",function(self) self:ClearAllPoints() self:SetPoint("CENTER",C_NamePlate.GetNamePlateForUnit("player"),0,-15) self:SetScale(0.8) end)
  4. ComboPointPlayerFrame:HookScript("OnHide",function(self) self:Show() end)

Anyone knows how to fix this?
  Reply With Quote
01-03-21, 02:53 AM   #2
3njoi
A Murloc Raider
Join Date: Dec 2020
Posts: 5
This macro works in game but doesn't work when I use it inside my addon no clue why
Lua Code:
  1. /run TargetFrameSpellBar:ClearAllPoints();TargetFrameSpellBar:SetPoint("CENTER",C_NamePlate.GetNamePlateForUnit("player"),"CENTER",0,47);TargetFrameSpellBar.SetPoint = function() end
  Reply With Quote

WoWInterface » Developer Discussions » Lua/XML Help » ComboPointPlayerFrame SetPoint

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off