Quantcast Missing icons for certain spell IDs - WoWInterface
Thread Tools Display Modes
04-02-17, 06:09 PM   #1
Ketho
A Molten Giant
AddOn Author - Click to view addons
Join Date: Mar 2010
Posts: 847
Missing icons for certain spell IDs

Since 7.2 the spell icon for specific Spell IDs isn't returned in-game, for example 210766 (Nightmare Pod)
http://wowprogramming.com/docs/api/GetSpellInfo
Lua Code:
  1. /dump GetSpellInfo(210766) -- "Nightmare Pod", "", nil, 0, 0, 0, 210766
Does anybody have an idea what's happening here?

I have an addon that tracks spells and it chokes on this particular one when I'm standing around in Dalaran
  Reply With Quote
04-02-17, 06:32 PM   #2
briskman3000
A Cliff Giant
AddOn Author - Click to view addons
Join Date: Mar 2009
Posts: 74
They changed GetSpellInfo in 7.0.3 to not return the texture info.

you should use GetSpellTexture to get the icon info

http://wow.gamepedia.com/API_GetSpellTexture

Last edited by briskman3000 : 04-02-17 at 06:44 PM.
  Reply With Quote
04-03-17, 12:21 AM   #3
SDPhantom
A Pyroguard Emberseer
 
SDPhantom's Avatar
AddOn Author - Click to view addons
Join Date: Jul 2006
Posts: 1,732
I've had GetSpellInfo() give the texture as the 3rd return up through 7.2. These have mostly been transitioned into textureIDs instead of paths since 7.0. It's still possible that the function is waiting for response from the server before returning all of the data. Functions like GetSpellTexture() perform local database lookups instead and as such, don't require querying the server.
__________________
ESOUI AddOns | WoWInterface AddOns
"All I want is a pretty girl, a decent meal, and the right to shoot lightning at fools."
-Anders (Dragon Age: Origins - Awakening)

Last edited by SDPhantom : 04-03-17 at 12:26 AM.
  Reply With Quote
04-03-17, 06:09 AM   #4
Ketho
A Molten Giant
AddOn Author - Click to view addons
Join Date: Mar 2010
Posts: 847
Yes, but for that specific spell Id 210766 GetSpellInfo just returns nil instead of any texture Id, even after querying it multiple times
  Reply With Quote
04-03-17, 08:18 AM   #5
Ketho
A Molten Giant
AddOn Author - Click to view addons
Join Date: Mar 2010
Posts: 847
There is something wrong with this icon spell_nature_lightningshield

I noticed these spells also are missing the icon when queried by GetSpellInfo
http://www.wowhead.com/spell=242319/opening
http://www.wowhead.com/spell=243134/opening
  Reply With Quote
04-03-17, 11:45 AM   #6
Banknorris
A Chromatic Dragonspawn
 
Banknorris's Avatar
AddOn Author - Click to view addons
Join Date: Oct 2014
Posts: 153
/run print(GetSpellInfo(192106)) works.

http://www.wowhead.com/spell=192106/lightning-shield

Maybe the problem is with item spells like those you mentioned.
__________________
"In this world nothing can be said to be certain, except that fractional reserve banking is a Ponzi scheme and that you won't believe it." - Mandrill
  Reply With Quote
04-03-17, 12:31 PM   #7
Ketho
A Molten Giant
AddOn Author - Click to view addons
Join Date: Mar 2010
Posts: 847
Yes maybe it's something to do with item spells?

Since it indeed works normally for http://www.wowhead.com/spell=192106/lightning-shield

Last edited by Ketho : 04-03-17 at 12:44 PM.
  Reply With Quote

WoWInterface » Developer Discussions » General Authoring Discussion » Missing icons for certain spell IDs

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off