Quantcast
Nil error for something I cannot track down - WoWInterface
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
05-24-21, 11:09 PM   #1
myrroddin
A Pyroguard Emberseer
 
myrroddin's Avatar
AddOn Author - Click to view addons
Join Date: Oct 2008
Posts: 1,203
Nil error for something I cannot track down

Attached is a zip of my WIP of RepByZone, as copying my Lua code will take up a lot of space in a thread. I do understand the error, but cannot explain what is causing it to happen. The variable that should have data is on line 141 of Core-Retail.lua, in the Onitialize function, and refreshed on line 6 of Options.lua just in case the user has changed something. Why Options.lua cannot see that variable, I don't know.

I need fresh eyes, methinks. The error dump is below.

Lua Code:
  1. 1x RepByZone\Options-Options.lua:77: bad argument #1 to 'format' (string expected, got nil)
  2. [string "=[C]"]: in function `format'
  3. [string "@RepByZone\Options-Options.lua"]:77: in function `member'
  4. [string "@Ace3\AceConfig-3.0-3\AceConfigDialog-3.0\AceConfigDialog-3.0-81.lua"]:221: in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:169>
  5. [string "@Ace3\AceConfig-3.0-3\AceConfigDialog-3.0\AceConfigDialog-3.0-81.lua"]:1211: in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1121>
  6. [string "@Ace3\AceConfig-3.0-3\AceConfigDialog-3.0\AceConfigDialog-3.0-81.lua"]:1652: in function `FeedGroup'
  7. [string "@Ace3\AceConfig-3.0-3\AceConfigDialog-3.0\AceConfigDialog-3.0-81.lua"]:1577: in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1561>
  8. [string "=[C]"]: ?
  9. [string "@Ace3\AceGUI-3.0\AceGUI-3.0-41.lua"]:72: in function <Ace3\AceGUI-3.0\AceGUI-3.0.lua:70>
  10. [string "@Ace3\AceGUI-3.0\AceGUI-3.0-41.lua"]:306: in function `Fire'
  11. [string "@Ace3\AceGUI-3.0-41\widgets\AceGUIContainer-TabGroup.lua"]:156: in function `SelectTab'
  12. [string "@Ace3\AceConfig-3.0-3\AceConfigDialog-3.0\AceConfigDialog-3.0-81.lua"]:1688: in function `FeedGroup'
  13. [string "@Ace3\AceConfig-3.0-3\AceConfigDialog-3.0\AceConfigDialog-3.0-81.lua"]:1932: in function `Open'
  14. [string "@RepByZone\Core-Retail.lua"]:196: in function `?'
  15. [string "@Ace3\AceConsole-3.0\AceConsole-3.0-7.lua"]:94: in function `?'
  16. [string "@FrameXML\ChatFrame.lua"]:5094: in function `ChatEdit_ParseText'
  17. [string "@FrameXML\ChatFrame.lua"]:4758: in function `ChatEdit_SendText'
  18. [string "@FrameXML\ChatFrame.lua"]:4794: in function <FrameXML\ChatFrame.lua:4790>
  19. [string "=[C]"]: in function `ChatEdit_OnEnterPressed'
  20. [string "*:OnEnterPressed"]:1: in function <[string "*:OnEnterPressed"]:1>
Attached Files
File Type: zip RepByZone.zip (187.3 KB, 100 views)
  Reply With Quote
 

WoWInterface » Developer Discussions » Lua/XML Help » Nil error for something I cannot track down

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off