Thread Tools Display Modes
11-26-23, 01:59 AM   #1
oilchameleon
A Defias Bandit
Join Date: Nov 2023
Posts: 2
Question LF someone to update or help me update NauticusClassic for Classic Era 1.15

This addon is fantastic, it was working perfectly when classic era originally released. I believe it was initially broken when the "tbc prepatch" was released.
I'm happy to learn how to fix it myself, if I could get some assistance. I have no experience with addons or, really, lua in general. Or if someone would take it upon themselves to update this addon, you'd have my thanks along with many other people's.

https://github.com/glajchs/NauticusClassic/tree/master
this is the most recent fork for the addon

https://github.com/psynct/NauticusClassic
this is the original addon that was working within classic era when I played with it.

Any advice here is good advice, open to any words on this at all.
  Reply With Quote
11-26-23, 11:59 AM   #2
Dridzt
A Pyroguard Emberseer
 
Dridzt's Avatar
AddOn Author - Click to view addons
Join Date: Nov 2005
Posts: 1,359
I pushed an update here https://github.com/Road-block/Nautic...eleases/latest
Test it and report back (I'm not really playing Era/HC atm)

I'll also send a pull request to the repo I forked.
  Reply With Quote
11-26-23, 12:34 PM   #3
oilchameleon
A Defias Bandit
Join Date: Nov 2023
Posts: 2
Hello!
I'm testing it right now, and Wow!
It looks to be working perfectly once again.
I cannot express how thankful I am, and I'm going to be sharing it with all of the boys.

If you don't mind my asking, what did you have to do to return it's function?
Curious to know how easy or difficult it might have been to fix if I had any experience with addons/lua.
  Reply With Quote
11-26-23, 12:53 PM   #4
Dridzt
A Pyroguard Emberseer
 
Dridzt's Avatar
AddOn Author - Click to view addons
Join Date: Nov 2005
Posts: 1,359
The error was coming from one of the embedded libraries.
Recent versions of wow have become stricter with what arguments can be passed to some methods.
Previously some methods getting empty or invalid arguments passed in, silently ignored them / reverted to a default behavior.

Now a lot of the interface code has moved to a more strict paradigm, where methods error if they don't get the exact arguments expected.

diff shows the breaking change.
I made a couple other small improvements to the versioning logic but addon would work without them.
  Reply With Quote

WoWInterface » AddOns, Compilations, Macros » AddOn Search/Requests » LF someone to update or help me update NauticusClassic for Classic Era 1.15

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off