Quantcast Help please, UIParent and OnReceiveDrag - WoWInterface
Thread Tools Display Modes
12-05-18, 12:37 AM   #1
Nightness
A Murloc Raider
AddOn Author - Click to view addons
Join Date: Feb 2009
Posts: 4
Help please, UIParent and OnReceiveDrag

I'm writing a button addon called MagnetButtons... I've recently run in to a weird snag...

Code:
-- This doesn't receive events, unless I also specify the OnMouseUp script...
-- But setting the OnMouseUp script breaks the ability to move by pressing
-- both mouse buttons down.
UIParent:SetScript("OnReceiveDrag", function (self)

end);

-- Can't use HookScript since UIParent:GetScript("OnMouseUp") == nil
UIParent:SetScript("OnMouseUp", function (self, button)

end);
Any suggestions?
  Reply With Quote
12-05-18, 03:14 AM   #2
Fizzlemizz
I did that?
 
Fizzlemizz's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Dec 2011
Posts: 941
Discussed here
__________________
Fizzlemizz
Maintainer of Discord Unit Frames and Discord Art.
Author of FauxMazzle and Move Pad Plus.
  Reply With Quote
12-08-18, 09:12 PM   #3
Nightness
A Murloc Raider
AddOn Author - Click to view addons
Join Date: Feb 2009
Posts: 4
Originally Posted by Fizzlemizz View Post
Discussed here
No kidding, that was my post.
  Reply With Quote
Yesterday, 08:34 AM   #4
jlam
A Deviate Faerie Dragon
AddOn Author - Click to view addons
Join Date: Oct 2010
Posts: 16
Originally Posted by Nightness View Post
No kidding, that was my post.
I believe he was just directing interested forum users to where the thread was hashed out since the discussion didn't take place here.
  Reply With Quote

WoWInterface » Developer Discussions » Lua/XML Help » Help please, UIParent and OnReceiveDrag

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off