Quantcast SetScale bug with frames - WoWInterface
Thread Tools Display Modes
12-08-18, 02:01 AM   #1
galvin
A Cobalt Mageweaver
Join Date: Nov 2006
Posts: 243
SetScale bug with frames

When Setting the scale. Its size is reduced.

Expected result is framesize shouldn't change, but visual size should be 5x larger

UPDATE: Did some more testing. If you setscale to MyBaseFrame it works fine. So there's a bug or something with setpoints and scale
Tested this on the PTR today, and still bugs out


Code:
local FrameBorder = {
   bgFile   = '',
   edgeFile = [[Interface\DialogFrame\UI-DialogBox-Border]],
   tile = true,
   tileSize = 16,
   edgeSize = 6,
   insets = {
      left = -4 ,
      right = -4,
      top = -4,
      bottom = -4
   }
}

if MyBaseFrame == nil then
   MyBaseFrame = CreateFrame('Frame', nil, UIParent)
   MyBaseFrame:SetSize(100, 100)
   MyBaseFrame:SetPoint('LEFT', 100, 0)
end

if MyScaleFrame == nil then
   MyScaleFrame = CreateFrame('Frame', nil, MyBaseFrame)
   MyScaleFrame:SetAllPoints()
end

if MyFrame == nil then
   MyFrame = CreateFrame('Frame', nil, MyScaleFrame)
   MyFrame:SetAllPoints()
   MyFrame:SetBackdrop(FrameBorder)
end

local MB = MyBaseFrame
local SF = MyScaleFrame
local MF = MyFrame


SF:SetScale(5)

C_Timer.After(1, function() print(MF:GetSize()) end)

Last edited by galvin : 12-08-18 at 12:27 PM.
  Reply With Quote

WoWInterface » PTR » PTR UI Bugs » SetScale bug with frames

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off