Quantcast
strange error - WoWInterface
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
08-23-19, 01:24 AM   #1
gmarco
A Frostmaul Preserver
 
gmarco's Avatar
AddOn Author - Click to view addons
Join Date: Dec 2009
Posts: 290
strange error

Hi all,

there is something I really don't understand well.

I got this error, and I have a gmTweaks addon, but I don't call PetFrame:Hide() function anywhere.

Lua Code:
  1. 2x [ADDON_ACTION_BLOCKED] AddOn 'gmTweaks' tried to call the protected function 'PetFrame:Hide()'.
  2. !BugGrabber\BugGrabber.lua:519: in function <!BugGrabber\BugGrabber.lua:519>
  3. [C]: in function `Hide'
  4. FrameXML\PetFrame.lua:81: in function `PetFrame_Update'
  5. FrameXML\PlayerFrame.lua:368: in function <FrameXML\PlayerFrame.lua:366>
  6. [C]: in function `PlayerFrame_SequenceFinished'
  7. FrameXML\PlayerFrame.lua:350: in function `PlayerFrame_UpdateArt'
  8. FrameXML\PlayerFrame.lua:274: in function `OnEvent'
  9. FrameXML\UnitFrame.lua:933: in function <FrameXML\UnitFrame.lua:931>
  10.  
  11. Locals:
  12. InCombatSkipped


The gmTweaks code can be found in gmUI or here:

https://is.gd/e3c4JK


Thanks all.
__________________
This is Unix-Land. In quiet nights, you can hear the Windows machines reboot.
  Reply With Quote
 

WoWInterface » Developer Discussions » Lua/XML Help » strange error

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off