Quantcast
"No Chilling Summons" has been created. - WoWInterface
Thread Tools Display Modes
09-21-21, 01:25 PM   #1
martigan30
A Murloc Raider
AddOn Author - Click to view addons
Join Date: Sep 2021
Posts: 5
"No Chilling Summons" has been created.

Imagine being a player level 48+ without the taint of having ventured into or taken any quests from Shadowlands. Now imagine being able to do Chromie Time at levels 48 and 49 without the issues of being stepped on by the inescapable quest "Shadowlands: A Chilling Summons." When that quest is in your log, you cannot switch to another expansion with Chromie, unless you switch to the current timeline.

No Chilling Summons is an addon that does three primary things:

1. It auto-abandons the quest "Shadowlands: A Chilling Summon."
2. It removes any talking head animations. Before I added this feature, Morgraine kept popping up every 20 seconds to tell us that we needed to go to Shadowlands. I didn't know how to identify a specific talking head, so I just disabled them all.
3. The text that comes with the talking head is filtered out based on the text "Shadowlands". You can test this by typing "Shadowlands" (case-sensitive) and see that you will not see it in the chat box.

There it is! You are Shadowlands free. Enjoy.
  Reply With Quote
09-24-21, 02:56 AM   #2
rulezyx
A Flamescale Wyrmkin
 
rulezyx's Avatar
Join Date: Jan 2020
Posts: 106
Seems a bit hardcore to me. Your addon avoids all talking-heads.

So people can't use this function combined with your addon.

No Immersion at all.

I didn't tried anything like that before but it is possible to "fake" max-level and maybe something like this will stop popups.

Lua Code:
  1. function GetEffectivePlayerMaxLevel()
  2.   return MAX_PLAYER_LEVEL_TABLE[GetExpansionLevel()];
  3. end
  4.  
  5. function IsLevelAtEffectiveMaxLevel(level)
  6.   return level >= GetEffectivePlayerMaxLevel();
  7. end
  8.  
  9. function IsPlayerAtEffectiveMaxLevel()
  10.   return IsLevelAtEffectiveMaxLevel(UnitLevel("player"));
  11. end

I guess your idea with blocking "forced" shadowlands content is not bad for alts but the current solution seems not user-friendly.
  Reply With Quote
09-25-21, 03:03 AM   #3
martigan30
A Murloc Raider
AddOn Author - Click to view addons
Join Date: Sep 2021
Posts: 5
Thank you for the suggestion. I think I may add that if a player is 48+ I will activate the addon. Really, there's no reason to even have the addon until you are 48.
  Reply With Quote
10-03-21, 01:51 PM   #4
martigan30
A Murloc Raider
AddOn Author - Click to view addons
Join Date: Sep 2021
Posts: 5
I made some changes to this addon. It's now available as version 1.2. I did run into an issue and I wasn't too happy with the workaround, but it works fine nonetheless. I used TalkingHeadFrame_CloseImmediately() to close the talking head window. There are two other methods, TalkingHeadFrame_Close() and C_TalkingHead.IgnoreCurrentTalkingHead(), both of which briefly display the talking head, which is annoying. The problem is, once TalkingHeadFrame_CloseImmediately() is run, I cannot get the talking heads back without having to call ReloadUI(). I tried unregistering and re-registering the events, but that did not work. I did not have to ReloadUI() when using the other two less-preferred methods of closing the Talking Heads window...but like I said earlier, their usage is annoying.

Changelog:

-------------------------------------------
I have added a slash command interface for this addon. The default values are:

Block "A Chilling Summons" quest = true
Block Talking Heads = true
Block "A Chilling Summons" talking head text = true
No Chilling Summons addon enabled = true

These settings can be changes with the following commands in-game:

-Type '/NCS Default' to set to default.
-Type '/NCS Shadowlands' to toggle the 'No Chilling Summons' blocker off and on.
-Type '/NCS Head' to toggle the talking heads blocker off and on.
-Type '/NCS Text' to toggle Morgraine's talking head text off and on.
-Type '/NCS Off' to turn off the addon.
-Type '/NCS On' to turn on the addon.

Also:

-Type '/NCS Help' to display these commands
-Type '/NCS' to display current settings

These settings will persist from session to session.
-------------------------------------------
  Reply With Quote
10-05-21, 12:13 PM   #5
martigan30
A Murloc Raider
AddOn Author - Click to view addons
Join Date: Sep 2021
Posts: 5
Originally Posted by Caperfin View Post
why is that?
The Shadowlands: A Chilling Summon doesn't pop up until 48. I decided to not filter based on level, but allow the user to change the settings in-game.
  Reply With Quote
10-07-21, 01:36 PM   #6
martigan30
A Murloc Raider
AddOn Author - Click to view addons
Join Date: Sep 2021
Posts: 5
Originally Posted by Caperfin View Post
huh interesting
Yep, it sure is.
  Reply With Quote

WoWInterface » AddOns, Compilations, Macros » Released AddOns » "No Chilling Summons" has been created.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off