Quantcast Custom sound files disabled? - WoWInterface
 
Thread Tools Display Modes
08-07-14, 11:58 PM   #1
galvin
A Frostmaul Preserver
Join Date: Nov 2006
Posts: 263
Custom sound files disabled?

I tried playing a custom sound file with PlaySoundFile() and I hear nothing. Is this disabled like custom textures were?
 
08-08-14, 08:11 AM   #2
def9
A Cobalt Mageweaver
 
def9's Avatar
AddOn Author - Click to view addons
Join Date: Jan 2008
Posts: 219
The code works for me in my little mod. How are you trying to play the sound? To make it work in a macro or just typing it in also works.

/script PlaySoundFile("Sound\\Spells\\AbolishMagic.wav")

Note the only wav files that will work are ones built into the wow client otherwise ogg or mp3 will be required.
__________________
Epiria, level 100 Ret/Holy Paladin
Simkin level 100 Combat Rogue
Feldeemus, level 100 Arcane Mage
 
08-08-14, 08:36 AM   #3
p3lim
A Pyroguard Emberseer
 
p3lim's Avatar
AddOn Author - Click to view addons
Join Date: Feb 2007
Posts: 1,694
That is not a custom sound file
 
08-08-14, 09:10 AM   #4
def9
A Cobalt Mageweaver
 
def9's Avatar
AddOn Author - Click to view addons
Join Date: Jan 2008
Posts: 219
Very true for some reason had a brain fart there. After trying an ogg of my own it did not seem to work. Kind of curious since dbm and gtfo use custom sounds and work fine in the beta. I even tried calling a couple of these mods sound files directly to no avail.
__________________
Epiria, level 100 Ret/Holy Paladin
Simkin level 100 Combat Rogue
Feldeemus, level 100 Arcane Mage

Last edited by def9 : 08-08-14 at 09:17 AM.
 
08-08-14, 11:50 AM   #5
freeqeust
A Defias Bandit
Join Date: Aug 2014
Posts: 2
I'm confused! I use the AddOn Hear Kitty and the sound-files can not be played since last build. But DBM and GTFO still works fine. And all of these addons use the same format, .ogg!
 
08-08-14, 12:02 PM   #6
p3lim
A Pyroguard Emberseer
 
p3lim's Avatar
AddOn Author - Click to view addons
Join Date: Feb 2007
Posts: 1,694
Format and encoding is not always the same thing, keep that in mind.
 
08-08-14, 12:22 PM   #7
freeqeust
A Defias Bandit
Join Date: Aug 2014
Posts: 2
Originally Posted by p3lim View Post
Format and encoding is not always the same thing, keep that in mind.
True story!

On a side note, it seems that custom sounds are in fact disabled/broken. The CUSTOM sounds from DBM is not working, just checked it out!
 
08-08-14, 02:46 PM   #8
Seerah
Fishing Trainer
 
Seerah's Avatar
WoWInterface Super Mod
Featured
Join Date: Oct 2006
Posts: 10,659
Unless something changed, custom sounds had been enabled when custom textures were. My addon Awwww! is working on the beta client (or was, as of the other day).
__________________
"You'd be surprised how many people violate this simple principle every day of their lives and try to fit square pegs into round holes, ignoring the clear reality that Things Are As They Are." -Benjamin Hoff, The Tao of Pooh

 
08-08-14, 03:40 PM   #9
galvin
A Frostmaul Preserver
Join Date: Nov 2006
Posts: 263
The custom sound file fatility doesn't play in bugsack.
 
08-08-14, 04:41 PM   #10
p3lim
A Pyroguard Emberseer
 
p3lim's Avatar
AddOn Author - Click to view addons
Join Date: Feb 2007
Posts: 1,694
Originally Posted by galvin View Post
The custom sound file fatility doesn't play in bugsack.
That is true, it must have been disabled in 18689.
 
08-08-14, 07:37 PM   #11
liquidbase
A Black Drake
 
liquidbase's Avatar
AddOn Author - Click to view addons
Join Date: Apr 2010
Posts: 82
Am I just out of. My whisper sound will also not play.
 
08-11-14, 11:17 PM   #12
galvin
A Frostmaul Preserver
Join Date: Nov 2006
Posts: 263
Still broken on latest build.
 
08-19-14, 10:10 AM   #13
freequest
A Kobold Labourer
Join Date: Jul 2010
Posts: 1
Seems like it is still broken in the lastest 18738 build
 
08-19-14, 01:32 PM   #14
Gello
A Firelord
AddOn Author - Click to view addons
Join Date: Jan 2005
Posts: 488
Do you guys think this is related to the inability to replace custom sound files over the default ones too? That's the Data\Sound\Spells\etc files we can create 0-length .ogg files to mute and stuff.

The folder structure is a bit different, so they could may be relocated someplace else. Has anyone tried and had any success?

I hope we're still able to replace default sounds. Sounds like Sound\Spells\JewelcraftingLoop.ogg make me crawl up the wall.
 
08-20-14, 09:09 PM   #15
galvin
A Frostmaul Preserver
Join Date: Nov 2006
Posts: 263
Hope they fix this, has anyone reported it?
 
09-03-14, 11:13 AM   #16
galvin
A Frostmaul Preserver
Join Date: Nov 2006
Posts: 263
Still broken on latest build.
 
09-09-14, 10:16 PM   #17
galvin
A Frostmaul Preserver
Join Date: Nov 2006
Posts: 263
Getting fixed
http://us.battle.net/wow/en/forum/to...2064?page=2#35
PlaySoundFIle() not working is a bug and should be fixed in a future Beta build.

In addition, functions that involve add-ons (GetAddonInfo, GetAddonDependances, etc.) should take the name or index.
 
09-10-14, 04:43 PM   #18
Phanx
Cat.
 
Phanx's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2006
Posts: 5,617
Originally Posted by galvin View Post
Can you post this in that thread for me?

Any chance of getting the C_PetJournal functions updated to work more like the new C_MountJournal functions, in that you can iterate over all the mounts without having to clear and restore all the filters? It's currently very tedious to work with the pet API, to such an extent that there's a dedicated library that does nothing but maintain an internal list of all the pets and provide a bunch of API wrappers. This seems like a clear case of designing the API around the UI, but it would be very nice to have an API that was just usable as-is.
Apparently an active EU account doesn't qualify me to post there.
__________________
Author/maintainer of Grid, PhanxChat, oUF_Phanx, and many more.
Troubleshoot an addonTurn any code into an addonMore addon resources
Need help with your code? Post all of your actual code! Attach or paste your files.
Please don’t PM me about addon bugs or code questions. Post a comment or forum thread instead!

Last edited by Phanx : 09-10-14 at 04:45 PM.
 
09-10-14, 05:16 PM   #19
galvin
A Frostmaul Preserver
Join Date: Nov 2006
Posts: 263
All done
 
09-10-14, 05:21 PM   #20
Haleth
This Space For Rent
 
Haleth's Avatar
Featured
Join Date: Sep 2008
Posts: 1,173
Slightly off-topic, but can you ask them if they can fix the item quality returns for GetInboxItem and GetSendMailItem? It always returns -1, even though the default UI is now meant to show item quality borders for mail items.
 
 

WoWInterface » Site Forums » Archived Beta Forums » WoD Beta archived threads » Custom sound files disabled?

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off