Quantcast 7.3 Broken PlaySoundFile()/PlaySound() - Page 2 - WoWInterface
Thread Tools Display Modes
11-03-17, 12:16 AM   #21
Habitamachine
A Defias Bandit
Join Date: Oct 2017
Posts: 2
Glad I found this. Used the unique sounds mute code for myself.
  Reply With Quote
12-09-17, 05:40 PM   #22
Kanegasi
A Frostmaul Preserver
 
Kanegasi's Avatar
AddOn Author - Click to view addons
Join Date: Apr 2007
Posts: 278
Originally Posted by Resike View Post
I did not generated myself since i would probably get the same table, but you can do it:

You can open the soundkitentry.db2 from the DBCFiles with WDBX then you can get the FileDataID for every SoundKitID, which would eventually point to a file name, if you crosscheck it with the lastly updated FileDataID. From there you need another table conversion from an older DBCFiles which helps with the Sound FilePath - SoundKit Name conversion, and tada.

Or you could just use the soundkitname.db2 and write the values out raw. But that's for non-masochists.
Coming back to this, I finally got around to getting WDBX. Your small note is what I ended up doing. I exported that list as a CSV, then with a few regex replacements, turned it into a Lua table. Easy.

Useless info: there are a total of 26 quotes in the whole list, 13 sound names have something in quotes. Also, 316 apostrophes and 80,575 total sounds.

Edit: Here's the table if anyone wants it (3MB): https://pastebin.com/yCsGYt2z raw: https://pastebin.com/raw/yCsGYt2z

Last edited by Kanegasi : 12-17-17 at 05:45 PM. Reason: added pastebin
  Reply With Quote

WoWInterface » AddOns, Compilations, Macros » AddOn Help/Support » 7.3 Broken PlaySoundFile()/PlaySound()

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off